itunes library strangeness - any suggestions?

Discussion in 'Mac Apps and Mac App Store' started by chrisnturkey, Nov 27, 2003.

  1. chrisnturkey macrumors newbie

    Oct 25, 2003
    About a week ago, itunes started losing songs from my library. I get the exclamation point and asked if I want to locate the file. The file is always right where it's supposed to be!

    My library is quite large (almost 9,000 songs) and on a dedicated disk (a slave). itunes is on the startup drive.

    I tried re-importing the whole directory - which added all the songs that were currently "lost" but it continues to loose songs.

    Oh, and can anyone tell me where the album art is stored? I will eventually buy a new machine and I will need to transfer my library to the new machine and I really don't want to loose all that laboriously downloaded artwork.

    Thanks folks!
  2. encro macrumors 6502


    May 6, 2002
    Large! Your library is massive :)
    mine is only 1713 Songs so I'm guessing your problems may be related to the large library. Some one else has mentioned quirky behaviour like this also happens when you have only a couple of gig of free space left on your blessed boot drive.

    As for the artwork, it's embedded into each related .aac file. Copy the file to a different system and it should be available straight away.
  3. bennetsaysargh macrumors 68020


    Jan 20, 2003
    New York
    make sure your iTune library file is on the same disk as all the files. that might work.
    also, this may sound stupid, but make sure i shows up as a disk on the desktop to double check that it is connected.

Share This Page