iTunes Metadata Is Grayed Out, Can't Edit

Discussion in 'Mac Apps and Mac App Store' started by SpaceKitty, Feb 15, 2012.

  1. SpaceKitty macrumors 68040


    Nov 9, 2008
    Fort Collins Colorado
    I can't edit any of my songs in iTunes. Selections are grayed out. How can I fix this, thanks!

    Attached Files:

  2. GGJstudios macrumors Westmere


    May 16, 2008
    Have you restarted iTunes? Restarted your computer? Are the songs located on an external drive? If so, is it mounted properly? Can you right-click and Show in Finder?
  3. jwheadrick macrumors newbie

    Oct 1, 2012
    File permissions

    I had a similar problem with some movies that I had in iTunes. I still haven't figured out how it happened, but the ownership/file permissions were messed up. Some were owned by me and were fully open (777) while others were owned by root and permissions were set at 744. To fix this, I ran this line while in terminal,

    sudo chmod 777 /Path/To/File/filename.m4v
    This will prompt for your admin password. You can do the same thing with other files, but you should make sure that it won't interfere with what a system admin may have set (if it's a work computer)

    (tip: to easily get the path to your file, you can simply drag the file into terminal and the full path will automagically be insterted)
  4. Just-me, Nov 14, 2012
    Last edited: Nov 14, 2012

    Just-me macrumors newbie

    Jun 6, 2008
    jwheadrick, thanks.

    Tried that in Mountain L.
    Doesn't work. I wrote the following in Terminal:

    SEs-MBP:~ Dad$ sudo chmod 777 /Users/Dad/Music/iTunes/iTunes\ Media/Music/2012-11-11\ iRip/Alice\ Deejay/Who\ Needs\ Guitars\ Anyway\?/Better\ Off\ Alone.m4a

    and gives me the following message:
    SEs-MBP:~ Dad$ 123qwe
    -bash: 123qwe: command not found

    Any ideas what would be the right one for ML?

    (BTW, after reading about the problems with permissions, with other songs I just went to the info and changed the permissions from there, but with this particular one also the lock in the info is grayed out).

    FOUND THE REASON: instead of Cmd+I I was clicking Option+Cmd+I (for a general info, for several files) and THAT gave me the grayed out lock, but when I did just Cmd+I could change permissions.

Share This Page