itunes no longer wants to share music

Discussion in 'Mac Apps and Mac App Store' started by ffuentes, Nov 4, 2003.

  1. ffuentes macrumors newbie

    Joined:
    Oct 25, 2002
    Location:
    LA
    #1
    Hello Everyone,

    Since the recent update of my itunes (to 4.1) I get an error message saying that port 3689 is being blocked by my software firewall, so users can't access my shared music. The funny this is my software firewall (Norton Personal Firewall) is deactivated and has been deactivated for some time. This has never happened before. What's going on and how can I fix it? Thanks for your time.:confused:
     
  2. Thanatoast macrumors 6502a

    Thanatoast

    Joined:
    Dec 3, 2002
    Location:
    Denver
    #2
    You're running osx?

    If you are, you have to open system prefs, load sharing, click the firewall tab, click the "new" button, and type in port 3689.

    This happened to me as well, found it after some digging and now it works great.

    One caveat, the first time another shared source showed up on my itunes, my network connection puked. I restarted and it worked fine, so a restart will probably help.

    Have fun! I'm listening to Blurry's James Brown collection right now!

    :)
     
  3. Rower_CPU Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Location:
    San Diego, CA
    #3
    Panther puts the iTunes port right in the listing for the firewall, so no need to add it or worry about putting in the wrong port number. Just enable it and you're set.
     
  4. ffuentes thread starter macrumors newbie

    Joined:
    Oct 25, 2002
    Location:
    LA
    #4
    itunes probs (con't),

    Sorry i should have mentioned that I am running itunes in jaguar. thank youu very much for your advice thanatoast, but i tried it and I got an error message saying that I am running other firewall sofftware, but I'm actually not. I even went into Norton Personal Firewall, enabled all access and even made a new service for port 3689 which all acess is allowed, and still no cigar.
     

Share This Page