iTunes not recognizing iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by chuckd62687, Sep 11, 2007.

  1. macrumors member

    Joined:
    Mar 15, 2007
    #1
    I am having a hard time with iTunes recognizing my iPhone. It is not the phone or cable as I took it up to the genius bar and it worked fine up there. I have tried numerous usb ports and I have the same issue with all of them. I assume it is iTunes but am unsure what to do to troubleshoot it. It works about 10% of the time.

    I am running a 17" PPC 800 MhZ iMac with all my iTunes data on an external Lacie 320GB disk which is getting close to full.
     
  2. macrumors member

    Joined:
    Apr 17, 2007
    #2
    iPhone won't Mount

    Having the same issue. 1 GHz G4, with USB 2.0 PCI card. iTunes or G4, can't see or won't see the iPhone. Restart is always required. Tried various scripts to force volumes to mount, no luck any thoughts?
     
  3. macrumors 68040

    synth3tik

    Joined:
    Oct 11, 2006
    Location:
    Minneapolis, MN
    #3
    Are you using iTunes 7.3 or 7.4. Also make sure you are using USB 2.0
     
  4. macrumors member

    o JRoD o

    Joined:
    Jul 11, 2007
    Location:
    Wisconsin
    #4
    I also can't get my G4 to recognize my iPhone in iTunes. I'm using the latest version of 7.4.1 (2). Previously if I "woke" up the phone, it would be seen in iTunes. Now nothing happens. I have tried to uninstall, and reinstall with no luck. My USB ports work fine with other devices.

    Any help would be appreciated.
     
  5. macrumors 65816

    ero87

    Joined:
    Jan 17, 2006
    Location:
    New York City
    #5
    same problem here! Mine is only recognized by my iMac G5 if I restart my computer, and then it only works that first time.

    It's good to hear that there are others with similar-sounding problems, maybe a software fix is on its way...
     
  6. thread starter macrumors member

    Joined:
    Mar 15, 2007
    #6
    I am using iTunes 7.4.1. Unfortunately, my iMac only has USB 1.1.
     
  7. macrumors 6502

    Joined:
    Feb 24, 2005
    Location:
    S. Floriduh
    #7
    Same problem here
    I've tried rebooting both computer and iPhone
    anything I can think of, no go?? :confused:
     
  8. macrumors newbie

    Joined:
    Jul 23, 2002
    #8
    I too am experiencing the same problem with a Belkin USB 2.0 card in a G4 1.0 GHz DP running 10.4.10. The only workaround I have been able to find is to connect the iPhone, put the computer to sleep, then wake the computer. When it wakes up, it then sees the phone.

    Not a great solution, but better than a restart. . .
     
  9. macrumors 65816

    ero87

    Joined:
    Jan 17, 2006
    Location:
    New York City
    #9
    i tried the sleep-wake technique, doesn't work. hmm....

    any other ideas? maybe it's because we put ringtones on our phones through that weird technique, could that be it? cuz it is a recent issue...
     
  10. macrumors member

    o JRoD o

    Joined:
    Jul 11, 2007
    Location:
    Wisconsin
    #10
    I was able to get iTunes to see my iPhone. Here are the steps I followed.

    1. Power off the iPhone.
    2. Close iTunes.
    3. Plug iPhone in via USB.
    4. Apple logo will appear for about 10 seconds, and then Power on.
    5. Reopen iTunes.

    Your iPhone should show up. If it doesn't the first time, try again! :)
     
  11. macrumors 6502

    Joined:
    Feb 24, 2005
    Location:
    S. Floriduh
    #11
    Thanks all,
    I tried everything and nothing was working for me. Weird thing was iPhoto saw my phone but iTunes.

    I uninstalled iTunes then re and it worked fine. Was a pain but it was my last option.
     
  12. macrumors newbie

    Joined:
    Jul 10, 2009
    #12
    still not working

    i've tried all of these and still nothing. i figured it would sure work when i reinstalled itunes, but it didn't.:confused: any other advice?
     
  13. macrumors newbie

    Joined:
    Feb 19, 2009
    Location:
    Orlando, FL
    #13
    Same here. I closed iTunes. Moved it into the trash from Apps folder. Emptied Trash. Restarted Macbook. Downloaded public version of iTunes from Apple site and installed. Reconnected iPhone to USB and was good to go.
     
  14. macrumors newbie

    Joined:
    Dec 9, 2008
    #14
    This Works!

    I'm running a Macbook Pro 10.5.8 w/ iTunes 9.0.1 and an iPhone 3Gs 3.0. I just got off the phone with Apple support. For those who have tried restarting iTunes, iPhone, computer, and re-installed iTunes with no luck. Issue may be caused because podcasts were downloaded to the iPhone directly and not with the desktop version of iTunes. Once I deleted the podcasts from my phone I was able to sync instantly upon plugging in the USB with no hang time at all. Try deleting your podcasts or any media downloaded to the phone directly.
     
  15. macrumors newbie

    Joined:
    Oct 16, 2009
    #15

    I thought for sure I was screwed! I deleted all my podcast and now it works.. What a crappy bug!!..

    Thanks Harpua585
     
  16. macrumors regular

    Joined:
    Nov 11, 2008
    Location:
    London
    #16
    Thank you!. Grrr, guess this hasn't been fixed yet as I have itunes 9.0.1.8 (win7) and iphone 3G 3.1.2
     
  17. macrumors member

    Joined:
    Aug 30, 2009
    #17
    Whenever I have that problem, shutting down the iphone, iTunes and then restarting normally do the trick. But I'm sure you've tried this already.
     

Share This Page