iTunes - play a single song

Discussion in 'Mac Basics and Help' started by retrovertigo, Aug 31, 2006.

  1. Guest

    #1
    I know this has probably been asked about 100 times, but I searched and I don't think I'm using the correct search terms. Anyway, I was wondering if there was a way to make iTunes play a single song (in other words, not move to the next one when the current song is done) aside from dragging it to the Source column and making it a single-song playlist?
     
  2. Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    Whakatane, New Zealand
    #2
    In the bottom-left corner is an icon of an arrow in a "loop". Click it twice.
     
  3. thread starter Guest

  4. thread starter Guest

    #4
    Actually, it doesn't look like that works. That just stops the current PLAYLIST from repeating. What I am looking for is a way for it to not skip to another song after playing the current song, when playing from the Library instead of a playlist. Is this possible?
     
  5. macrumors 68000

    Veldek

    Joined:
    Mar 29, 2003
    Location:
    Germany
    #5
    This button has several modes that you can click through: no repeat, repeat all or repeat one. The last one is the one you want, I think.
     
  6. thread starter Guest

    #6
    No, repeat 1 only repeats the same song. I want to play one song and be done. The only way I see to do this is to drag it to the left column and turn it into a one-song playlist, which is pretty lame.
     
  7. macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #7
    You're right, iTunes isn't able to do what you want easily. It's yet another Apple interface blunder.

    Here are some workarounds:

    - Drag the song over to the playlist bar (so that you have a playlist of one song). Delete the playlist when you're done.

    - Enter the song title into the search box until only the one you want is displayed (or is at least at the bottom of the list), then select and play.

    - Ctrl-click the track and show song file. Put the Finder window into column mode and play it from the preview.

    - Install this into your scripts menu (you should have Script Editor under Applications/Applescript to make it into a proper script file).
     
  8. thread starter Guest

  9. macrumors 68040

    Killyp

    Joined:
    Jun 14, 2006
    #9
    It's even easier than that. Just type the full name of the track, with the artist name into the spotlight search in the top right of iTunes...
     
  10. macrumors 65816

    Joined:
    May 14, 2003
    #10
    This is something that has had me scratching my head for some time, but I never bothered to figure out why.

    Sometime when I play a song it will play that 1 and stop, exactly what the OP is asking how to do. Nothing else will play after that 1 song, even if its from a multi track cd. Other times it will play that song then go into the next song and continue to play until the end of the list.

    There doesn't seem to be any rhyme or reason why it does this from 1 time to the next. I'm not making single song play lists, I'm not hitting repeat 1 or anything else that might cause this behavior.

    What I do it select the artist I want from the library list, choose the cd I want, then select the 1 song I want. Sometimes it plays the next song from that cd, and other times it stops after the song I selected. Weird.
     
  11. macrumors 68040

    miniConvert

    Joined:
    Mar 4, 2006
    Location:
    Kent, UK - the 'Garden of England'.
    #11
    I always just drag the one song into it's own new playlist. I guess it's not ideal, but I've never really thought twice about it!
     
  12. macrumors 68020

    ChrisBrightwell

    Joined:
    Apr 5, 2004
    Location:
    Huntsville, AL
    #12
    If you uncheck a song, it won't be played "next."

    If you uncheck *all* songs, you disable the "automatic track forward" feature of iTunes, meaning that it will play that song and stop until you tell it to play another song.
     
  13. macrumors 6502a

    Thanatoast

    Joined:
    Dec 3, 2002
    Location:
    Denver
    #13
    But it's not possible to uncheck all the songs in the library and have them only checked in the playlist. That'd be a great solution, but once a song is checked in the playlist, it becomes checked in the library. I think retrovertigo has a legitimate beef. Apple should fix this.
     
  14. macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #14
    Yep, and the other problem is that you lose the checkbox's iPod sync usefulness if you go messing around like that. This really should be another state on the shuffle button or something.
     
  15. macrumors newbie

    Joined:
    Mar 23, 2014
    #15
    Playing single songs on iTunes

    I had the same problem and was very frustrated with the answers I got from the workers in my Apple Store. I was putting on a show and didn't want the music to continue until I was ready for it. Searched everywhere with no luck. Then one day it came to me. First create your playlist of the songs you want included. Then uncheck the check next to each song in the list. When you double-click a particular song, it will not repeat or go to the next song. Couldn't believe how simple the solution was!
    RDevinoff
     
  16. macrumors newbie

    Joined:
    Dec 8, 2014
    #16
    Here is a solution, do you see the symbol beside the Apple that looks like three dots and three lines? After you play the song that you want click on it and click clear all so that no other songs will play next. I use this software regularly and performance and found that this is the best way to do it! If this is the best solution please mark me as best answer! Always search Jamin Tymes for all of your stock audio music and instructional needs.
     

Share This Page