iTunes plays song, but iPod won't

Discussion in 'iPod' started by tech4all, Oct 29, 2006.

  1. macrumors 68040

    tech4all

    Joined:
    Jun 13, 2004
    Location:
    NorCal
    #1
    I have this .wav file that plays fine in iTunes, but for some odd reason when I try to play it on my iPod, the iPod reverts back to the main menu. I tried reseting the iPod while holding down Menu and the center button, but nothing. iPod is 4G with black and white screen (40GB) and iTunes 7.

    Any ideas? :confused:

    P.S. While attempting to play the song on my iPod now I noticed that if I pause the song before it goes back to the main menu and I click the center button so I get the seek mode, I can scroll throughout the song, but when I stop scrolling the little dot goes back to 0:00. It's as though the iPod thinks the song is 0:00 long. Weird.
     
  2. macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #2
    You could set up the iTunes preferences to do imports as AIFF for now (set it up to match whatever settings are used by the WAV, from its get info panel), and then ctrl-click to convert that track. That ought to bypass whatever is in the way, and it leaves the original WAV intact just in case.
     
  3. Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    Whakatane, New Zealand
    #3
    iTunes and iPods use different decoders, and as such they handle damaged files differently. I've seen countless (well OK, two :eek:) files that play perfectly in iTunes but not on my iPod. A lossless conversion has worked in both cases.
     
  4. macrumors 68020

    Joined:
    Mar 21, 2006
    Location:
    Hoosiertown
    #4
    change to lossless encoding and change .wmv to it. The ipod supports lossless better.
     
  5. thread starter macrumors 68040

    tech4all

    Joined:
    Jun 13, 2004
    Location:
    NorCal
    #5
    Thanks everyone for their reply's. :)

    I'm somewhat did what you guys said. I right clicked the file and converted it to AAC instead of WAV. I updated my iPod to reflect the change, and it seems to play fine now. That's odd as I never encountered this problem where iTunes could play a file but the iPod can't.

    Thanks again!
     

Share This Page