iTunes problem in Lion 10.7

Discussion in 'Mac OS X 10.7 Lion' started by haylsx, Jun 7, 2011.

  1. macrumors newbie

    #1
    Hi! I own a Macbook Pro 15" from June 2007, and it's always been ran on Snow Leopard until the other day when I installed the developers version of OS X Lion 10.7.

    I have been having nothing but problems ever since, although I like the new interface and the added extra bits it's been a real problem with my concerning Java updates and iTunes especially.

    Whenever I try to open iTunes, i get the following message

    Process: iTunes [208]
    Path: /Applications/iTunes.app/Contents/MacOS/iTunes
    Identifier: com.apple.iTunes
    Version: 10.3 (10.3)
    Build Info: iTunes-10305401~1
    Code Type: X86 (Native)
    Parent Process: launchd [144]

    Date/Time: 2011-06-07 23:09:58.337 +0100
    OS Version: Mac OS X 10.7 (11A390)
    Report Version: 8

    Interval Since Last Report: 77466 sec
    Crashes Since Last Report: 23
    Per-App Crashes Since Last Report: 17
    Anonymous UUID: D1196BEE-7DB4-4F8C-A1C5-58D151E97408

    Crashed Thread: 0

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000

    Application Specific Information:
    @executable_path/../Frameworks/iPodUpdater.framework/Versions/A/iPodUpdater

    Dyld Error Message:
    Library not loaded: @executable_path/../Frameworks/iPodUpdater.framework/Versions/A/iPodUpdater
    Referenced from: /Applications/iTunes.app/Contents/MacOS/iTunes
    Reason: unsafe use of @executable_path in /Applications/iTunes.app/Contents/MacOS/iTunes with restricted binary

    Binary Images:
    0x1000 - 0xe50ff3 com.apple.iTunes (10.3 - 10.3) <C8678F1E-ED2F-3BAF-44AE-ECCF9F0D108D> /Applications/iTunes.app/Contents/MacOS/iTunes
    0x8fe00000 - 0x8fe3320b dyld (195 - ???) <33A6763E-295E-3FE1-9594-81B9E296BACC> /usr/lib/dyld

    I have tried uninstalling and reinstalling iTunes, I have tried deleting certain hidden files using terminal. I just can't get no luck. I wouldn't be as bothered but iTunes is a really crucial application for me.

    Attached is some images I thought might be useful to anyone trying to figure this out with me!

    Thanks in advance, Hayley :)
     

    Attached Files:

  2. macrumors 6502a

    PurrBall

    #2
    DP4 contains a newer version of iTunes, you should use the version that's on the disk image instead of 10.3.
     
  3. macrumors 68030

    #3
    iTunes 10.3 is the most recent, but his Lion build does not look like 11A480b, it looks like he is using "OS Version: Mac OS X 10.7 (11A390)". iTunes 10.3 might need DP4( 11A480b ).
     
  4. Bear, Jun 7, 2011
    Last edited: Jun 7, 2011

    macrumors G3

    #4
    If the person were a developer, they would have the right version of iTunes. iTunes 10.3 as downloaded from the regular Apple web site is not for Lion, especially not for DP4.

    And you're half right, 10.3 is the latest released version of iTunes.

    Edit: Maybe iTunes 10.3 is meant for DP4 as well, but it's still not the latest version for at least iPhone developers.
     
  5. macrumors 68030

    #5
    I'm running iTunes 10.3 on DP4. iTunes 10.3 shows up as a software update on DP4 and is not available as a download from the dev site, but you can get it from Apple.
     
  6. #6
    Try installing iTunes 10.5 beta from Apple's Dev Connection. That's the most up-to-date build.
     
  7. macrumors newbie

    #7
    hmmm tried installing 10.5 beta but no luck, also removed it completely and installed 10.1 but again, haven't got it working. looks like i'm going to have to get 10.6.7 back on my mac and just wait till lion comes out in july!

    thanks for all your help guys!
     
  8. macrumors regular

    #8
    Make sure to file a bug with Apple.
     
  9. roblawton, Jun 13, 2011
    Last edited: Jun 15, 2011

    macrumors 6502

    #9
    Just come home from work to find iTunes giving me exactly the same error!

    Tried the usual steps so resorting to reinstalling iTunes 10.5 beta.

    If I went back to 10.3 - iTunes wouldn't let me open the Library file as it was created by a newer version...

    Hopefully there may be a way to roll back if it doesn't work! :/


    EDIT: IT WORKED! (Phew!)

    So if you have this problem, re-download and install the 10.5 developer build of iTunes and you should be fine!

    (Edit 2: Changed 10.3 to 10.5)
     
  10. macrumors member

    #10
    Where can you download this from? It won't let me download iTunes 10.3 from their website as it says I have a newer version. Please advise.
     
  11. macrumors 6502

    #11
    Sorry about that, I meant 10.5.

    As my library had been rebuilt by 10.5, 10.3 would not open. So I had to re-download the 10.5 developer preview from Apple's Developer Portal.
     

Share This Page