1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

iTunes Problem - No option for remotes or remote speakers

Discussion in 'iPod' started by milbournosphere, Apr 20, 2012.

  1. macrumors 6502a

    milbournosphere

    #1
    I'm not sure where to post this, so I'll try here. After updating iTunes to v10.6.1, I have lost my ability to use remotes (via remote app on my iPad and iPhone) and remote speakers (an aTV on 4.2.2). I've turned on Home Sharing, and tried to enable iTunes to look for remotes, but to no avail. In fact, the option isn't even there in the preferences->devices window; I've attached a screenshot where it should be (at least from my understanding). You can also see that the usual menu for speakers in the lower right corner is nowhere to be found.

    I have tried restarting itunes, restarting the mac, trashing the iTunes preferences and reinstalling iTunes. Nothing has solved the issue. Has anybody else had this problem? Remote control and the ability to play my music throughout my home are my favorite features of iTunes, so this is somewhat upsetting. :(
     

    Attached Files:

  2. LaWally, Apr 20, 2012
    Last edited: Apr 20, 2012

    macrumors 6502a

    #2
    I've had this problem a couple of times.

    Shutting down my iMac for the night and powering it up the next morning has always cleared the problem for me. Recycling iTunes has never worked for me.

    Sorry I can't be more helpful.
     
  3. macrumors 6502

    #3
    Have you tried using your iOS devices' Remote app and manually adding your iTunes library? Have you done anything new to your WiFi network recently? Maybe its blocking the needed ports (which I don't know at the moment).

    Maybe try creating a new user account and see if it works there? If it does, then it may be an issue with an app maybe interfering with iTunes in some way or another. If it doesn't work on the new user account, then maybe its a problem with your network.

    Sorry I can't help much, I hope you can resolve this.
     
  4. macrumors 6502a

    milbournosphere

    #4
    Thought I'd update this thread for anybody else having the issue. My networking issues got worse, until I couldn't even SSH into the machine remotely. Then I noticed that my roommate was also having networking issues. A hard restart of the router and walaa! airplay and such are working again. Still not sure what happened; I guess the router got into a funk.
     
  5. macrumors 6502a

    #5
    Whenever I have these kinds of issues, I restart the router and all is good again.
     

Share This Page