iTunes-purchased tracks aren't playing on my iPod?

Discussion in 'iPod' started by omgwut, Jan 25, 2007.

  1. macrumors 6502


    Jul 28, 2006
    Hey there,
    I've had a few albums purchased off of the iTunes store on my Ipod for a good while now, but I recently did something (presumably connected it to a machine with an outdated iTunes client) and that somehow screwed up the music I bought.

    Now, when I try selecting one of the songs I purchased on my iPod, it won't play any of them, and just skips them by like 1-2-3 until it lands on a track it will play. I know this is some copy protection BS, but what can I do to fix it? I already plugged it back into my Mac and authorized the machine, but its still doing it.

    gah wtf.
  2. Moderator


    Staff Member

    Dec 7, 2002
    Whakatane, New Zealand
    So they're playing successfully on your computer?
  3. thread starter macrumors 6502


    Jul 28, 2006
    Never mind, I got it working again, thanks to Senuti. For whatever reason it just a simple drag off of the iPod, and they played again after I put them back on. Weird..

    Thanks for trying to help me, though.
  4. macrumors G3


    Aug 20, 2003
    sitting on your shoulder
    If it had been a FairPlay issue, the songs wouldn't have been on the iPod at all.
  5. macrumors member

    Dec 21, 2006
    Well i had this once or twice on my nano and i simply did the reset thing ... u know holding down menu and select (or something like that)
    did the job for me .

Share This Page