iTunes stopped working; won't play anything

Discussion in 'Mac Apps and Mac App Store' started by bshegg, Oct 30, 2005.

  1. bshegg macrumors newbie

    Joined:
    Oct 30, 2005
    #1
    After messing with the language files in the itunes directory to fix an unrelated itunes language problem, itunes suddenly stopped working. I'm not sure if there is any connection between the two, or if it was just coincidence.

    iTunes opens without any problems, but when I try to play any kind of files, it aknowledges the file and brings up the song information, but it won't play. The same thing happens when trying to listen to samples from the music library.

    I've tried everything I can think of including uninstalling, deleting all of the itunes associated files on the computer and in the registry, and reinstalling (the new version).

    I'm not quite ready to give up and reformat, does anyone have any ideas?

    I'm using a PC with the most recent version of itunes.

    Thanks
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Do you get a grey circle with an exclamation mark in it next to songs you try to play?

    Have you deleted the file inside the iTunes folder named iTunes Library? :)

    What exactly did you do to the language files?
     
  3. bshegg thread starter macrumors newbie

    Joined:
    Oct 30, 2005
    #3
    No, I don't get the missing file icon, and I'm pretty sure it's not a problem with the library because it can't play music store samples either. Regardless, I did delete the library file, along with every other itunes related file I could find.

    The language files issue is sort of a long story, but to make it short, the language settings in my itunes got screwed up when a friend downloaded some korean updater files for his ipod. After reading some forum posts I learned that the only way you can change the language in itunes is to transfer files from the C:\Program Files\iTunes\iTunes.Resources directory. What I had to do was replace the corrupted files from the ja.lproj directory (originally installed japanese, later corrupted to incoherent korean) with the en.lproj directory so that it would be in English. This solved the language problem, but now I can't play any files. I have since then uninstalled, deleted all itunes files, and reinstalled the new version of itunes with no improvement.

    The only thing that I can think of is that iTunes has some sort of secret built in defense mechanism that I triggered by messing with the itunes files which has permenently corrupted my computer to itunes. Unfortunatly I read too much science fiction, and I need a more rational mind to tell me what really happend.

    Please, if anyone has any ideas...I'm desperate!
     
  4. jholzner macrumors 65816

    jholzner

    Joined:
    Jul 24, 2002
    Location:
    Champaign, IL
    #4
    Well, I'd like to mentionthat I am having the exact same problem. Can't play any music or samples from the music store. I didn't mess with anything other than updating to iTunes 6 and it started. I reinstalled and updated to 6.1 but still not working. Its really pissing me off. Apples support page was useless. They have the problem listed for Windows (I'm using Windows at work) but it only gives a fix for WinXP and I'm on 2000.
     
  5. lolex macrumors member

    lolex

    Joined:
    Nov 3, 2005
    Location:
    where ever the Sun shines
    #5
    Did you tried switch back to itune 6.0 see if it works? I 'm yet not update to itune6.1 since 6.0 works perfectly to me now.

    Actually , Itune happened to be hang-up once before when I messed up with other installations, and I needed remove either installations n reinstalled them,
    lucky me, they works fine finally.:)
     
  6. stromy44 macrumors newbie

    Joined:
    Nov 13, 2005
    #6
    properties

    i went to properties and went under compatiblity; then changed compatiblity from windows 98 to windows NT and that did it for me.
     

Share This Page