iTunes Wi-Fi Sync Problems!

Discussion in 'Mac Apps and Mac App Store' started by TW95, Nov 30, 2012.

  1. TW95, Nov 30, 2012
    Last edited: Nov 30, 2012

    TW95
    Expand Collapse
    macrumors member

    Joined:
    May 26, 2010
    Location:
    London
    #1
    I think this may be quite a common problem but...

    I have been having problems with my iTunes Wi-Fi sync for some time now, the problem is that devices don't show in iTunes, or sometimes they show when they want to.

    There are 2 iPhone 5s 2 iPhone 4Ss and an iPad 3rd gen that have been synced with iTunes. It seems that the devices only show over Wi-Fi when they want to, if ever.

    There are various solution online including:

    Restart iPhone and computer (Tried, doesn't work)
    Reinstall iTunes (Tried, doesn't work)

    I am using iTunes 11 and OS X 10.8.2 running on a Mid-2009 MacBook Pro 13".

    Any ideas?

    EDIT: it only seems to be my iPhone 5 that isn't appearing, the other 3 appear, no problem.
    EDIT 2: Sync over Wi-Fi IS checked.
     
  2. steve knight
    Expand Collapse
    macrumors 68000

    steve knight

    Joined:
    Jan 28, 2009
    #2
    I now just close down itunes and restart it that usually works.
     
  3. TW95
    Expand Collapse
    thread starter macrumors member

    Joined:
    May 26, 2010
    Location:
    London
    #3
    Thanks for the reply.

    Unfortunately that doesn't work for me :-(
     
  4. steve knight
    Expand Collapse
    macrumors 68000

    steve knight

    Joined:
    Jan 28, 2009
    #4
    I used to have to connect with my charging cable on a usb port let it sync turn off wifi sync hit apply then choose wifi sync and hit apply again. then I found closing itunes would do it.
     
  5. benhollberg
    Expand Collapse
    macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #5
    I have the same problem. If I want to Wi-Fi Sync then I have to restart iTunes every time. Also syncing with the cable doesn't always work. I just gives me an error. Been happening for at least a month or since I got my iPhone 5. This happens with two iPhones and two iPads syncing.
     
  6. steve knight
    Expand Collapse
    macrumors 68000

    steve knight

    Joined:
    Jan 28, 2009
    #6
    After a bit it acts just liek the last version. I have to manually hit sync or restart itunes or hook to the computer and change from wifi sync to regular and back.
     
  7. fjfjfjfj
    Expand Collapse
    macrumors regular

    Joined:
    Mar 20, 2009
    Location:
    New York, NY
    #7
    Same here, nothing seems to work consistently. Sometimes restarting itunes works, sometimes not. Sometimes restarting the phone works, sometimes using the USB works...very frustrating.
     
  8. IzzyJG99
    Expand Collapse
    macrumors 6502

    Joined:
    Oct 26, 2007
    #8
    I've had this problem on and off since they introduced Wi-Fi sync. Sometimes they'll show up. Sometimes they don't. Sometimes they'll appear like 30 minutes after I open iTunes. Not sure what the deal is and why it wasn't addressed several revisions of iTunes ago. Sometimes even the hardwire cable method doesn't work.

    A good example was I got my iPhone 5 today. I plugged it into iTunes to restore from my old iPhone 4 back-up. It didn't show up for about 5 minutes. I just sat here waiting.
     

Share This Page