iTunes Won't Let Me Rename Certain Songs

Discussion in 'Mac Basics and Help' started by SahDu, Sep 17, 2006.

  1. SahDu, Sep 17, 2006
    Last edited: Feb 15, 2014

    macrumors newbie

    Joined:
    Sep 12, 2006
    #1
    So, I was going through my iTunes (v7) and it woulnd't allow me to change the name, artist, etc. on certain songs. Some it would no problem, but with the others, when I bring up the "Get Into" dialogue box, the entire "Info" tab is greyed out. Any suggestions? Thanks!
     
  2. MOFS, Sep 17, 2006
    Last edited by a moderator: Feb 15, 2014

    macrumors 65816

    MOFS

    Joined:
    Feb 27, 2003
    Location:
    Durham, UK
    #2
    Are you the administrator of the computer? If not, you may not have permission to rename them. If the songs have been imported b someone else's login on the computer, that may be the problem. If you want to fix that, you just need to change the permissions of the iTunes folder.
     
  3. SahDu, Sep 17, 2006
    Last edited: Feb 15, 2014

    thread starter macrumors newbie

    Joined:
    Sep 12, 2006
    #3
    I was pretty sure I had permission, as I was able to change other songs in the same folder. However, I went back and made sure to give myself "Full Control" of the folder. I closed and reopened iTunes with no change. Thanks for the attempt though. Anything else I could try? I just dont understand why this would happen.
     
  4. macrumors 6502a

    rtdgoldfish

    Joined:
    Jul 4, 2004
    Location:
    Tallahassee, FL
    #4
    Are they files that you ripped from a CD or are they downloaded tracks from the music store?? You can't edit the track info for a protected AAC file from the music store.
     
  5. macrumors 68000

    spicyapple

    Joined:
    Jul 20, 2006
    #5
    Two other things you can check.

    1. Are the files locked? Use Finder to unlock.
    2. Update or convert the ID3 tags to the latest version. This can be done in iTunes.

    If all else fails, you may try re-encoding them again. That will surely fix the probably. Depending on what is used to encode the MP3 file, especially with VBR encoding, it sometimes doesn't work well in iTunes.
     
  6. SahDu, Sep 17, 2006
    Last edited: Feb 15, 2014

    thread starter macrumors newbie

    Joined:
    Sep 12, 2006
    #6
    They are downloaded files, but I figured out the problem. After looking at the files a bit closer, I noticed that the ones I couldnt rename happened to be read only (why this is the case I have no idea). I was able to change all the file permissions in the folder using a select all and changing the properties that way. I apologize for the inconvenience. Thanks though!
     
  7. don't care, Aug 4, 2008
    Last edited by a moderator: Feb 15, 2014

    macrumors newbie

    Joined:
    Aug 4, 2008
    #7
    ughh... i hate computer problems... i had this problem b4 cuz i was transferring the music from my ipod to my new computer... i ignored it for a while but then i just decided to fix it the other day...

    k... have u tried converting the song to .mp3 thats the only way ive found to get around this problem... right click on the song> convert selection to ... (it should, by default, say convert selection to aac... i just have mine set up for mp3 cuz im an mp3 kinda guy but it should work either way) > then it will make a kind of copy, after that you can rename the new file and delete the old one... unless im misunderstanding the problem this should work for u... good luck
     
  8. dizzybabyyy, May 26, 2010
    Last edited by a moderator: Feb 15, 2014

    macrumors newbie

    Joined:
    May 26, 2010
    #8
    That worked perfectly!!

    I was confused why iTunes wasn't letting me rename my songs. I went to my Music Folder > Edit > Select All. Then I right-clicked and clicked properties then unchecked the "read-only" box and now I'm allowed to edit my songs.

    Thanks,
    Brandy
     
  9. macrumors newbie

    Joined:
    Jul 29, 2011
    #9
    Itunes info won't change song names and stuff...LOL!

    :)
    OK, I had a hard time but it worked. I'll make it as simple as I can.
    I have used itunes for 8 years to DJ. When I got this Windows 7 PC I had the same problem. Some songs, info in itunes was grayed out. I think this will work for most everyone.
    If you haven't already. Put your songs,files and folders in one big Master Folder. That means if you are not set up like that you need to (Delete them out of the Itunes list) then drag the Master folder back into the Itunes music library. Get a cup of coffie. It's slow here..Don't mess with Itunes anymore, ,close it out (exit for now.)
    Go to the Master Folder--Properties--in Attributes take out everything in the boxes.---then click apply--then advanced---check the second box it say something like allow files and folder to be indexed..etc.---then OK.--Next is the shareing tab.---share button---share wit5h everyone in there--highlite and share button--put check in box(Share this fodler)--add master folder name as share folder---click apply--next tab--Security---advanced--must make all say---allow and full control--- apply. I also went costomize tab and checked optmize for MUSIC--checked sub folder then Apply. Now restart your PC. Then Itunes. It worked for me!
     

Share This Page