iTunes wont play albums

Discussion in 'Mac Apps and Mac App Store' started by WRXHokie, Apr 4, 2007.

  1. WRXHokie macrumors regular

    WRXHokie

    Joined:
    Sep 12, 2005
    Location:
    New Jersey
    #1
    My iTunes library is extensive, and thus i have only a small number of my library checked for syncing on my Nano. I then manage my Nano by having it only sync the checked items in my library.

    The problem is now when i play mp3's from my library, it will only play the checked items for some reason. If i select an album in cover flow to listen to, it will only play the first track from the album, and then it will stop after that song is over. When i hit the right arrow button to play the next track it will skip to the next item in my library that is checked and play that. How do i tell it to stop doing that? I dont want to just play checked items all the time.

    Also, i'm not playing a playlist of any kind, this is just selecting songs from my library in cover flow mode or the other views.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Rather than sync checked songs only with your iPod, set up a playlist (or multiple playlists) to automatically sync with the iPod instead. This way you can keep everything synchronised easily, whilst still being able to play all your music continuously. :)
     
  3. WRXHokie thread starter macrumors regular

    WRXHokie

    Joined:
    Sep 12, 2005
    Location:
    New Jersey
    #3
    Is this the only way around this problem? Seems like kinda a dumb way to do thing in my opinion.
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    It works for me. I can help you streamline the transfer, if you like. Just create a new Smart Playlist, uncheck Match The Following Rule, check Match Only Checked Items and Limit to some ridiculously large number of songs/GB/hours or whatever.


    Picture 1.png


    This Smart Playlist should then have all your checked songs. Now, create a new regular playlist. Select all the songs in the Smart Playlist and drag them to the regular one. These items are destined for your iPod.

    Head to the iPod settings in iTunes and opt to sync songs from a certain playlist (this newly created one) rather than to sync all items (but only checked ones). Now, as that's syncing, head back to the iTunes library and whilst holding COMMAND (on a Mac), click an unchecked song to turn them all checked again.
     
  5. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #5
    The point of having the check marks is to tell what songs to play and not play without having to actually remove them from the library.

    Your method of only checking a few songs seems like quite a hassle to me. Have you tried telling iTunes to shuffle by album? Or another thing I do is I setup a smart playlist that only allows songs that haven't been played in 20 days to show up. Keeps everything mixed up reeeeeal good.
     

Share This Page