iweb help

Discussion in 'Web Design and Development' started by pamijo, Mar 2, 2007.

  1. pamijo macrumors newbie

    Oct 28, 2006
    I am so new at iweb, i am trying to add a link on my iweb page. Does anyone know how to do that? I am not a computer person at all so please make it easy for me. Also can you add pdf files, that will enlarge when clicked on? Thanks PJ
  2. dobbin macrumors 6502a


    Jan 28, 2002
    First select whatever it is you want to be the link - e.g. a picture or some text.

    Then go into the inspector (click the I button at the bottom of the window).

    In the inspector, click the link tab (the one on the right hand side that has a little blue/white arrow).

    Use the options there to either link to one of your pages or an external page somewhere else on the web.

    I think a good tip is to keep "make all links inactive" selected at all times. This does not make them inactive on your published pages, just within iWeb while you are designing the pages.

    I don't think you can add a .pdf file directly - you will need to convert it to a .jpg first.
  3. Mydriasis macrumors 6502


    Mar 17, 2005
    I dont use iWeb... but I think you may be able to add a pdf by pointing a link to it.

    Try it and let us know if it works.
  4. pamijo thread starter macrumors newbie

    Oct 28, 2006
    Mailing list

    I need to know how to add a mailing list to my web site. I am using iweb of course, is this possible to add? Thanks PJ

    Like phone number, address, email,etc....
  5. aaron.lee2006 macrumors 65816


    Feb 23, 2006
    Ontario, Canada
    iWeb Enhancer lets you add HTML codes. You could try that.
  6. Labecmedia macrumors newbie

    Mar 7, 2010
    iWeb Troubles -- Please Help!

    I have been using iWeb for over a year and I have a lot of my work on it. But for some reason, when I went to open iWeb, I get the error message:
    Can’t open file “~/Library/Application Support/iWeb/Domain.sites2.”
    Does anyone know how I can fix this and make sure my content doesn't get deleted?

    Thank You!
  7. Alphakline macrumors regular


    Nov 30, 2003
    Los Angeles, CA
    Well for starters, is that file still there? If not do you use Time Machine? You can restore that file from your TM backup. If you have no back up and the file is not there then you lost everything my friend. You will need to recreate it and the only way to do that is to start from scratch.
  8. RobinN macrumors newbie

    Jan 5, 2010
    I have been working with iweb for quite some time.
    I have a new issue. A few of my pics on my website show up in iweb but on the site are replaced with ?s.
    I also just noticed that the same photos in my FB album are also replaced with ?s.
    I tried replacing the images on my iweb, but it did nothing for the site.

    Any ideas?
  9. angelwatt Moderator emeritus


    Aug 16, 2005
    Got a link? You may have forgotten to upload the images or maybe they're just pointing to the wrong spot.
  10. RobinN macrumors newbie

    Jan 5, 2010

    The problem is contained to: Landscape Paintings

    I uploaded the photos like all the rest, and I use to be able to view them.
    I have also tried replacing them. When I click on the ?s I am linked to their larger version.

    The site also doesn't seem to be publishing correctly
    I tried to put a note about site issues on that page, and it won't publish.
  11. angelwatt Moderator emeritus


    Aug 16, 2005
    They do not seem to be uploaded, at least not to the correct location. One of the images not found has an expected URL of
    but that image does not exist in the Landscapes_Paintings_files directory, which I am to view from my browser as a listing. Make sure the files are uploaded to the correct folder.
  12. RobinN macrumors newbie

    Jan 5, 2010
    Thanks, that will give me a place to begin looking.

Share This Page