Java apps not running

Discussion in 'Mac Programming' started by AlmostThere, Jan 15, 2007.

  1. macrumors 6502a

    I have been having some problems running Eclipse on my PB - it is simply not running.

    After the splash screen, it provides a message box saying that there has been an error and dumps a log file containing this information to the configuration folder:

    !SESSION 2007-01-15 10:01:00.110 -----------------------------------------------
    java.vendor=Apple Computer, Inc.
    BootLoader constants: OS=macosx, ARCH=ppc, WS=carbon, NL=en_US
    Framework arguments: -keyring /Users/almost/.eclipse_keyring -showlocation
    Command-line arguments: -os macosx -ws carbon -keyring /Users/almost/.eclipse_keyring -consoleLog -showlocation

    !ENTRY org.eclipse.osgi 4 0 2007-01-15 10:01:01.431
    !MESSAGE Application error
    !STACK 1
    java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    at java.lang.reflect.Method.invoke(
    at org.eclipse.core.launcher.Main.invokeFramework(
    at org.eclipse.core.launcher.Main.basicRun(
    at org.eclipse.core.launcher.Main.main(

    Eclipse was just un-tarred to /Applications (last year's version was trashed). My best guess is that there is something amiss with the Java set up on my Mac (everything is fine on my Linux workstation, so no crisis) but I don't know that much about how Apple's Java is set up.

    The ORM app I have been using, CayenneModeller, also written in Java as an app bundle, also fails to run.

    Are there any Java preferences / Eclipse preferences I can trash / settings I can check at System / user level to ensure everything is correct for running app bundles. Possibly even permissions?

    Command line Java tools are running fine and some Java GUI apps are OK.

    I would like to get this lot back up and running on my laptop.

    The output from running Eclipse on the command line -debug -clean -consoleLog
    Start VM: /usr/bin/java
    -jar startup.jar
    -os macosx
    -ws carbon
    -launcher /Applications/eclipse/
    -name Eclipse
    -showsplash 600
    -exitdata 70002
    -vm /usr/bin/java
    -jar startup.jar
    Unable to access jarfile startup.jar

    startup.jar is in the /Applications/eclipse directory which makes me think this is a configuration problem...
  2. macrumors 6502

    Oct 24, 2005
    I have never had trouble with my eclipse on my mac (all troubles has been in windows). In the terminal window do a, java -version. See if your jdk is pathed properly.

    startup.jar should be in the eclipse directory

Share This Page