Java problems, Mac OSX 10.4

Discussion in 'OS X' started by debonair, Aug 13, 2011.

  1. macrumors newbie

    Joined:
    Aug 13, 2011
    #1
    For a couple months now, my java has completely stopped working. I have tried to find the answer numerous times, and the only thing I found was to re-install OS for my mac. I really don't want to go through that.

    None of my java applications load any more when they were working perfectly fine a couple of months ago. Is there any way to revert back to the earlier javas/ get it working again, and how I can prevent this from happening again?
    My system runs OSX 10.4 (Tiger I believe)

    thanks in advance for any help
     
  2. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    You can always re-apply the latest Java update for your version of Mac OS X (10.4 "Tiger") - that sometimes gets things working again.
     
  3. thread starter macrumors newbie

    Joined:
    Aug 13, 2011
    #3
    is there any specific way to re-apply java?

    I have tried re-downloading the latest update for version mac OSX 10.4 to no avail
     
  4. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    What error message did you get when you tried to install the update?
     
  5. thread starter macrumors newbie

    Joined:
    Aug 13, 2011
    #5
    it doesn't give an error. In fact it says 'software was successfully installed', but the problems still persist even when I re-start the computer and browser.

    Do you suppose there is a way to delete java and re-install it?
    I'm completely stumped
     
  6. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    I don't recommend trying that on a Mac, due to the way Java is integrated with the rest of the system. You're likely to break more than you fix. That said... try going into Java Preferences and making sure things are right there. It's in your Utilities folder.
     
  7. thread starter macrumors newbie

    Joined:
    Aug 13, 2011
    #7
    I guess I'm not sure what's 'right' in this case.
    When I open up Java under utilities, a folder named J2SE 5.0 holds the Java Preferences.
    Under 'Java Version' is listed:
    J2SE 1.4.2
    J2SE 5.O

    J2SE 5.O was originally selected, but I changed it to J2SE 1.4.2 but it didn't seem to make a difference.
    I'm guessing there is something else I have to do, but I'm not sure what. Either under the preferences or some other settings I have to manually change.
     

Share This Page