Phones Just switched from Iphone to Samsung, not recieving txt messages

Discussion in 'Alternatives to iOS and iOS Devices' started by purplekush604, Oct 8, 2013.

  1. macrumors member

    Joined:
    Sep 19, 2011
    #1
    Hey guys

    As the title says i just recently switched from an iphone to a samsung galaxy s4. I noticed a lot of people with iphones are not able to text me. I turned my old phone on wifi. and had a ***** load of texts/imessages. Does anyone know a solution here?
    FYI i did read on the thread if i goto message settings and click the sms toggle it should work, but still not getting some messages.
    Thanks
     
  2. macrumors 6502

    Joined:
    Apr 1, 2011
    Location:
    Cebu, Philippines
    #2
    Maybe network problems?
     
  3. macrumors 601

    tbayrgs

    Joined:
    Jul 5, 2009
    Location:
    Florida, USA
    #3
    Sounds like you didn't turn off iMessage on your iPhone--very common problem iPhone users experience when switching (myself included). You'll need to remove your phone number from iMessage on any iDevice or Mac where you use iMessage and then turn off iMessage on your old iPhone.
     
  4. macrumors member

    Joined:
    Jan 19, 2012
    #4
    Just switched from Iphone to Samsung, not recieving txt messages

    You will want to turn off iMessage on all of your apple products, then go to this website https://idmsa.apple.com/IDMSWebAuth...URL=https://supportprofile.apple.com/homePage

    And login and remove all of your devices. Following that if you are still having issues have your friends delete the conversation thread that they have with you and start a new thread and manually type your phone number into the send field. It should work from then on. Sometimes it still takes a couple hours to kick in after you perform these steps.
     
  5. thread starter macrumors member

    Joined:
    Sep 19, 2011
    #5
    Awesome thanks guys imessage off and 4s unregistered
     
  6. macrumors 6502a

    Joined:
    Apr 25, 2006
    #6
    If that doesn't work, another thing to try is to reset your Apple ID password. I had to do that over the weekend and I have to tell you, I this should be way easier than it is.
     
  7. macrumors 68040

    Joined:
    Jul 28, 2007
    #7
    Actually Apple finally fixed this problem with ios6. iMessage with sim switchers (like me who switched from iOS to other platforms was an utter mess)

    When you originally linked iMessage it was probably linked to your @me.com (or other Apple ID). But iOS 6 gives you option to finally choose your physical phone number which makes it a lot easier on people who like to switch phones and switch from iOS to windows or android phones.
     

Share This Page