Keep getting iMessage activation alert

Discussion in 'iOS 5 and earlier' started by 3bs, May 28, 2012.

  1. 3bs
    macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #1
    I restored my phone and I'm on 5.1.1 and for some reason I keep getting he activation alert telling me my carrier might charge me for the SMS activation. The same happened for FaceTime, I kept getting an alert but I turned it off and I stopped getting it but somehow now it's back on but I'm getting alerts r iMessage instead.
     
  2. 3bs
    thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #2
    I've also noticed that when people iMessage me on my number I get it and also if they send it to my Apple ID but when I iMessage them they receive it from my email although I have my caller ID set to my phone number
     
  3. 3bs
    thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #3
    I've tried 5.1.1 twice now and it won't seem to activate iMessage or FaceTime. I went back to 5.0.1 and I don't have this problem. Any ideas why?
     
  4. macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
  5. 3bs
    thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #5
    3 Ireland. This is really annoying. If I turn off FaceTime it starts doing it for iMessage. I notice I only get this when I'm not on wifi.
     
  6. macrumors 603

    Carlanga

    Joined:
    Nov 5, 2009
    Location:
    PR
    #6
    Something similar happened to me on 5.0 when I went for a trip and used another sim then replaced it w/ my orig carrier sim and the iCloud phone number activation go stuck without me even realizing it until people started telling me why I was not answering their imsjs back... I went to settings for each thing and for example in message settings I turn it off then on and that seemed to activate it properly; did the same w/ all the other apps.... If not maybe try resetting the network settings?
     
  7. 3bs, Jun 2, 2012
    Last edited: Jun 2, 2012

    3bs
    thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #7
    I tried turning off iMessage and FaceTime. Let me try resetting network settings. The weird thing is this is the 2nd time I restore and setup as new and it's happened both times.

    edit: also something weird I've noticed is that in Settings > Phone > My Number isn't actually my number even though when I text or call someone, my number shows up.
     
  8. macrumors 603

    Carlanga

    Joined:
    Nov 5, 2009
    Location:
    PR
    #8
    let me know if resetting fixed it for you.
    Are you jb? do you use a sim interposer? which hacks are you running if jb? Are you using a number that was not the one registered w/ the iPhone? in iCloud do you have the sim card # or is it another one?
     
  9. 3bs
    thread starter macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #9
    So I've noticed that I get these activation messages whenever I restart my phone and it's fine until I restart again. My number in FaceTime and iMessage are correct but in Phone it's not my number. It's a temporary number which 3 was provides until my number is switched from my old carrier (Vodafone). I switched months ago so not sure why it's showing up now.

    ----------

    Nope. Doesn't seem to have fixed it but at least now I only get the activation method when I reboot. I am jailbroken but never had this issue on 5.0.1. My phone is factory unlocked. I'm using the same tweaks as I did on 5.0.1 so I doubt that's the issue. Not using iCloud at the moment.

    Reading some posts from here and and it seems like I just need to get a new sim card. I'll try that tomorrow. I hope this fixes it. I'd rather stay on 5.1.1 than go back to 5.0.1 https://discussions.apple.com/thread/3401647?start=0&tstart=0
     

Share This Page