keyboard acts as if the ctrl key is pressed down

Discussion in 'Mac Basics and Help' started by lenbust, Mar 17, 2007.

  1. lenbust macrumors newbie

    Mar 17, 2007
    I am on a MacBook, and my problem is that the system acts as if the ctrl key is pressed down at all times, which means that I can't left-click anything and -- worse! -- that I can't type(!) on the keyboard.

    Pressing num lock actually lets me single-click (until I press down ctrl and click on the mouse again, at which time the system reverts to the behaviour described above). I can still not type, though.

    This started after updating to 10.4.9. While updating and when rebooting for the first time after the update I had an external mouse (USB) plugged in.

    I have experienced the same problem before however. It happened both when I had an external mouse plugged in and when I did not. Difference is that the other times it happened I was able to get the ctrl key to unstick pretty easily by plugging in a USB mouse (with a proper right mouse button) and clicking around on the two buttons on that for a while. Restarting the machine helped half of the times as well.

    This time, however, I have no such luck.

    I do not believe this is a hardware issue, as in a physically stuck key, but rather some software error. I have of course tried to clean out anything that might be stuck under the ctrl key, I have tried to shake any possible dirt out of the keyboard, and I have tried using an external USB keyboard -- all to no avail. (Is there a way to fully disable the built-in keyboard and use only an external one?)

    Also, this poster experienced something similar, although his problem was that alt+command were stuck. His solution was to unstick the keys by pressing ctrl+f1. Could there be a similar combo for unsticking the ctrl key?

    I have the kernel extension DoubleCommand installed. It's likely that it is not compatible with the new 10.4.9. The only active setting in DoubleCommand is "Caps Lock acts as ctrl key", and that sure sounds as a suspect. However, since it is a System Preference, disabling that option requires that I authenticate with the system by typing my password -- which I obviously can not! Quite the catch-22.

    So in conclusion, it might be a hardware problem (that the key is actually pressed down or that something is stuck inside the keyboard), a general software problem (seeing how this has happened before), or, which seems most likely, a case of incompatibility between 10.4.9 and DoubleCommand.

    All ideas on how to solve this are most welcome!
  2. smokeyrabbit macrumors 6502

    May 19, 2005
    Escape from New England
    Restart holding the shift key down in Safe Boot mde. If the problem persists it will be hardware.
  3. lenbust thread starter macrumors newbie

    Mar 17, 2007

Share This Page