Keyboard does not work when booting into XP

Discussion in 'Windows, Linux & Others on the Mac' started by potlatch, Dec 28, 2006.

  1. potlatch macrumors member

    Joined:
    Dec 5, 2006
    #1
    The keyboard on my MBP is rarely recognised when I boot into XP, so I cannot even select which Windows profile I want to load.

    Basically, I would say 33% of the time, the keyboard will load, but most of the time, I have to switch off and reboot at least three times until the keyboard works in DOS.

    I searched the boards here, but didn't find a solution.

    Is there a solution to this? What's causing it in the first place? Oh, and everything works fine in Parallels.
     
  2. blaster_boy macrumors 6502

    blaster_boy

    Joined:
    Jan 31, 2004
    Location:
    Belgium
    #2
    Not too sure about the solution, but does an external keyboard work ?
     
  3. potlatch thread starter macrumors member

    Joined:
    Dec 5, 2006
    #3
    I haven't got an external keyboard, and shouldn't need one.
     
  4. blaster_boy macrumors 6502

    blaster_boy

    Joined:
    Jan 31, 2004
    Location:
    Belgium
    #4
    Of course you shouldn't need one, but it might have helped you out in a spot and perhaps if you found out that it also didn't work, it might help to locate the problem...
     
  5. LonewolfSX macrumors newbie

    Joined:
    Dec 30, 2006
    #5
    I am having the exact same problem. I even tried re-installing the OS X driver list. my friend has a USB keyboard so I plugged it in while booting and it worked fine, but the mac keyboard doesn't work until I am in the OS, sometimes. It's not a huge thing, but it does really suck having to reboot over and over again until the keyboard works.
     

Share This Page