Keyboard for PPC G4

Discussion in 'PowerPC Macs' started by canhoto, Sep 12, 2011.

  1. macrumors member

    Mar 10, 2011

    My old 1999 (iMac) keyboard isn't working so well, so I was looking for a new keyboard to use with My PowerMac G4 (Sawtooth). But I searched in Apple's store and, worse than the fact the keyboards are extremely expensive when compared with other brand's keyboards, it seems that the (wired) keyboard Apple is selling works only with 10.6.8 as a minimum requirement!

    That makes it impossible to use with G4.

    Any ideas? Are there any new keyboards that can be used with 10.5.8?

  2. macrumors 6502a

    May 8, 2011
    Endwell, NY
    The Apple aluminum wired keyboard works with 10.5.8 just fine, there is a software update so the function keys work properly. I use it on my G5 Quad. As long as you're running leopard there shouldn't be a problem.

    If you want a more generational-specific keyboard to your iMac, search for the "Apple Pro Keyboard" on eBay.
  3. Guest

    May 12, 2011
    Apple is funny with peripherals min requirements. I bought the full lenght white keyboard (newest model) last year, it said I could not use it under tiger, and guess what?... It works even under mac OS 9. A keyboard is a keyboard, this makes no sense to put min req like that, unless you really really want to be 100% sure those special shortcut keys nobody really need will work... lol
  4. macrumors 65816


    I bought the 1st Aluminum wired keyboard shortly after it came out, and it worked on my G3 smurfbox running OS 9....and am still using it with my Quicksilver & 10.5.8 :)

    Most USB kb's (and mice) work with OS X nowadays, especially MS & logitech ones
  5. macrumors newbie

    Oct 16, 2011
    I have a G5 Dual 2.3 GHz PowerPC Mac running OSX 10.5.8 - I note that the iPad 2 is compatible with this - I am in need of a new keyboard for my G5 and I am considering purchasing an iPad 2 as an eBook reader. I note that all the latest Apple keyboards state minimum requirements as OSX 10.6.8 including a new one with a docking stand for the iPad - was this stated for your new Aluminium keyboard in May?
  6. macrumors 65816


  7. macrumors 68020


    Mar 13, 2005
    Yes the OS requirement really just means that you need that OS for every single key to function properly. I use one of the aluminum keyboards myself and love it. I get access to all the keys as I run 10.5.8.
  8. macrumors 68040


    Sep 17, 2009
    the Apple USB aluminium keyboards work with any computer that has a usb port,
    the 10.6.8 minimum requirement on the USB Keyboards is a marketing trick
    to convince you to buy a Mac now if yours cant run OSX Snow leopard ;)
    The alu keyboard works well on my PC's running windows7 and linux distro's and on my iMac G3's , eMac's , PowerMac's running OSX Tiger
  9. macrumors 6502

    Sep 15, 2010
    Los Angeles & Northern California
    Running a G-4 Sawtooth, OS 10.5.8. 2 years ago I bought the $100, Apple Pro keyboard. Clear plastic over white base. The Get Info command tells me the KB version is 4.2, whatever that means.

    All function keys work as expected. Buy one of eBay if the stores no longer stock them.
  10. macrumors 68040


    Sep 17, 2009
    the older Apple keyboards are favoured by me too
    not only because of their clean white look , no i actually find they are better suited for writing then the modern aluminium ones , but that's personal preference

Share This Page