Keychain doesn't seem to remember me...

Discussion in 'Mac Apps and Mac App Store' started by Mechcozmo, Nov 14, 2005.

  1. Mechcozmo macrumors 603

    Mechcozmo

    Joined:
    Jul 17, 2004
    #1
    My System Keychain seems to have issues. It occasionally (about once every two days) asks for my System keychain. So, I type in my admin password and it fails. I click Cancel, open Keychain Utility proper, and click the unlock icon. Type in my password (same one) and like magic it works. :confused:

    This was pre-10.4.3 BTW. My login keychain is fine. :confused:
     
  2. Sedulous macrumors 68000

    Sedulous

    Joined:
    Dec 10, 2002
    #2
    I had the same problem. Some people reported that the system keychain could be repaired using the Keychain Access.app. That didn't work for me and I couldn't be bothered to tinker with it, I just did a clean install (which worked). Or, alternatively, you can delete the system keychain (which I also did). While deleting the syskeychain didn't overtly damage anything, I was not interested in going "down that road"... it must be used for something.
     
  3. Mechcozmo thread starter macrumors 603

    Mechcozmo

    Joined:
    Jul 17, 2004
    #3
    I forgot to mention I've run the Keychain First aid. Nada.
     
  4. Sedulous macrumors 68000

    Sedulous

    Joined:
    Dec 10, 2002
    #4
    Well, one other think I tried was to copy the system keychain from another computer. But eh, that didn't work (big surprise). I have no further tips on how to get rid of that. Maybe this is one of the bug fixes reported to be in the 10.4.4 update!
     
  5. Yaja123 macrumors regular

    Joined:
    Mar 19, 2005
    #5
    i had this same problem after update. It was very annoying and i was on the verge of a complete reinstall because my preferences kept going as well but somehow it seems to have repaired itself - maybe with my help?

    I was restoring from Backup 3.0 for a few days everytime it went funny then i eventually tried deleting acouple of keychains. One was the idisk/.mac keychain as everyday when it was about to sync it would pop up with "null" message & not sync and then after that the keychain file itself corrupted. I think maybe acouple of your keychains are corrupt.. try deleting one and then repair and see what happens. Abit of a suck it and see.

    I also tried to repair it using the first aid but it said there was nothing to repair.

    As i said it seems to work perfectly now and has been for a week. Saved me doing complete re install. Goodluck.
     
  6. Mechcozmo thread starter macrumors 603

    Mechcozmo

    Joined:
    Jul 17, 2004
    #6
    I only have login, System, and X509Anchors keychains. I did reset Keychain once, but it kept on happening. I don't have an iDisk, nor a .Mac, so that isn't a problem.
     

Share This Page