KotOR: Dantooine issues

Discussion in 'Games' started by Lord Blackadder, Aug 21, 2006.

  1. Lord Blackadder macrumors G5

    Lord Blackadder

    Joined:
    May 7, 2004
    Location:
    Sod off
    #1
    I ran through Knights of the Old Republic on my laptop (15" 1.33GHz G4, 1.25GB RAM, Rad 9700/64MB) and performance was good except for the planet of Dantooine. No matter what settings I turned off then game became a slideshow whenever I left the Jedi Enclave. In fact whenever I am "outside" the framerate plummets. None of the other planets have this problem.

    I thought this might be an issue with the speed of my hardware (maybe that map is the most demanding on the hardware). But it does nearly the same thing on my desktop, which should be considerably faster...I can turn the settings up much higher with my PowerMac and get good framrates - except on Dantooine, where even with everything turneed down the game is barely playable. what gives?
     
  2. ghall macrumors 68040

    ghall

    Joined:
    Jun 27, 2006
    Location:
    Rhode Island
    #2
    I've had the same problem. I think this became an issue sometime after the 10.4.3 update (at least it did for me), since then there has not been a patch to fix this issue. I'm as stumped as you are.
     
  3. wingsky macrumors member

    Joined:
    Jan 17, 2006
    Location:
    UK
    #3
    You are definitely not alone here. Dantooine is notorious for its low frame rate on Macs, especially your first encounter with the raiders just outside the enclave.

    There is no fix as far as I know, and considering the age of the game now, I don't think there ever will be.
     
  4. Lord Blackadder thread starter macrumors G5

    Lord Blackadder

    Joined:
    May 7, 2004
    Location:
    Sod off
    #4
    Well, at least I'm not crazy...

    Fortunately the rest of the game was fine.
     
  5. tubagruv macrumors newbie

    Joined:
    Jul 26, 2006
    #5
    Yep, it's a sort of bug in the way later versions of OS X (post-KotOR-release) do their OpenGL stuff. I'm not too well-versed on it, I think that the tweaks to up the frame rate for Quake 3 kill a few spots in KotOR, most noticeably, Dantooine.

    Workaround: find the "swkotor.ini" file, and under Graphics Options, insert this line:

    Disable Vertex Buffer Objects=1

    Your CPU will handle that bit of graphic processing, which drops your framerate a bit, but Dantooine is now playable. Once you're out of there, you can get rid of that option to put your framerate to max again.
     

Share This Page