lacie porsche 250G

Discussion in 'Mac Accessories' started by steakface, Aug 8, 2005.

  1. steakface macrumors newbie

    Joined:
    Aug 8, 2005
    #1
    hi,

    I have a big problem with my drive... he just stop working. For no particular reasons. It's as if there is no power. I've tchek with a another power cord from a another identical drive... and nothing. I turn the switch to on and the light doesnt turn on and there is no sounds... nothing... dead... Is there anyone that herd a similar problem... I sure hope i can fix it because i have important data on this drive.

    by the way, does anybody knows if it's possible to take out the drive out the case and put it inside my computer (i have a mac g4 twin processor 867mhz)... it could solve my problem if the broken part is not the hard drive.

    tkx

    frank
     
  2. jamesW135 macrumors 6502a

    jamesW135

    Joined:
    Apr 30, 2005
    #2
    If this is just that harddrive then maybe its time to send it to the company or get it fixed. If others work its obviously not the mac. :)

    Is it USB or firewire?
     
  3. steakface thread starter macrumors newbie

    Joined:
    Aug 8, 2005
    #3
    finally

    after looking at my papers... i realize that the warranty is over... i call lacie and they told my to send it... and that they will make a verification... but i have to pay for the repair... so i took the decision to open it... and finally it was quiet easy... i took it out and the drive inside is a maxtor hd ATA pretty standard. the only thing that i had to do is to take out a pin to set the drive to slave and i install it into my computer... i saved a lot of money. he is not portable anymore... but all the data is intact and for the money it had cost me to get it fixed... i will buy a another one...

    end of the story
     
  4. xsedrinam macrumors 601

    xsedrinam

    Joined:
    Oct 21, 2004
    #4
    Hmm. A Maxtor inside a LaCie. Are you sure "he" wasn't a "she"? :cool:
    X
     
  5. steakface thread starter macrumors newbie

    Joined:
    Aug 8, 2005
    #5
    hummm

    hummm...
    I didn't take time to tcheck the sex... but it was a Maxtor :)
     

Share This Page