Lacie Portable Drive USB Problems

Discussion in 'Macintosh Computers' started by monkeybushman, Mar 23, 2005.

  1. macrumors newbie

    Joined:
    Mar 23, 2005
    #1
    Hey guys,

    I having some problems that hopefully someone can help me out with. I bought a 40GB Lacie Mobile USB Hard Drive for my G4 Powerbook. My computer does not see the drive, and when I go to drive utilities, the drive doesn't show up. The external hard drive doesn't seem to be spinning even though the power indicator is on. I tried to hook up the external hard drive to my roommate's PC, and it worked. Then I had a friend bring his powerbook over, and his powerbook recognized the drive and was working fine. I checked my USB ports and they both work for my other accessories (USB mouse). I even used an external power supply for the drive thinking it is a lack of power supply to the USB port. I tried unplugging the powerbook, I've tried zapping it, and all possible combinations. No luck! Any suggestions or thoughts?

    confused and frustrated
    monkeybushman
     
  2. macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #2
    For starters, what model PowerBook do you have? And what model did the drive work on?
     
  3. macrumors regular

    anotherjeff

    Joined:
    Dec 7, 2004
    Location:
    Honolulu
  4. thread starter macrumors newbie

    Joined:
    Mar 23, 2005
    #4
    My powerbook is the 1.5 GHz 17in 80GB one. The powerbook that it worked on was the older generation 15in one (the titanium, I believe). Both are running the same version of Mac OSX 10.3.8.
     

Share This Page