Lag lag lag why can't we jailbreak without having lagging problems?

Discussion in 'Jailbreaks and iOS Hacks' started by alphatectz, Apr 22, 2009.

  1. macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #1
    ok I jailbroke my 3g again and guess what at first everything was great theny iphone started to lag, first was sbssettings problems
    with opening settings from the dock takes about 4 seconds to open or it just get stuck and I have to reopen it. Then the keyboard then clippy then auto correct, then icons start to dim(even of I didn't select an app) what about the stock SMS it takes up go 3-5 seconds to open.
    I only installed about 4 3rd party apps. WTF!!!! I hate this. I think I'm just goi go to restore and just wait until the full 3.0fw comes out unless someone has a better solution?????
     
  2. macrumors 65816

    DannyBres

    Joined:
    Oct 30, 2007
    Location:
    UK
    #2
    what were the 3rd party apps u installed?
     
  3. macrumors member

    McKnight

    Joined:
    Mar 29, 2009
    #3
    The quality of code isn't the same, so jailbroken stuff runs slower, that's the nature of the game.
     
  4. thread starter macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #4
    Let's see, I have status notifier, iblack list, winterboard (which I only use with transparent dock) extended preffences (which I never use on winter board) sbssettings, clippy and cyrecorder (which I never use) My iPhone never use to be so laggy after a jailbreak now it's just sucks.
     
  5. thread starter macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #5
    that's not entirely true.
     
  6. macrumors member

    fuz10n

    Joined:
    Mar 29, 2009
    Location:
    Charlottesville, VA
    #6
    i have a jailbroken iphone 3G, and have also had bad lag experiences with winterboard and sbsettings. I re-jailbroke and manually installed my own dock png file with dock reflections i made on my own in Gimp and 5 icon dock, and it's snappy as a non-jailbroken phone.

    so quality of code or not, take it from this user who has tried both ways and look into just picking a theme you really like and will stick with and manually install it without winterboard. (It takes some research and time, but you will avoid those lag issues). And stay away from sbsettings and just use boss preferences.
     
  7. thread starter macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #7
    So let me get this right, you no longer have your iPhone jailbroken, but you managed to have a transparent dock and reflect on your iPhone? An you do a FCSB too if so pass that file over and let me know what you did (well how you manually did everything)
     
  8. macrumors member

    fuz10n

    Joined:
    Mar 29, 2009
    Location:
    Charlottesville, VA
    #8
    It is jailbroken, but I only installed cydia, ssh, 5 icon dock, and boss preferences.

    To manually apply a winterboard theme without winterboard, you have to go through each app you have installed and replace its icon with the icon of your choice via SSH. For appstore apps, they are in a different place than the cydia apps. (check out http://www.modmyi.com/forums/skinni...appstore-installed-app-icons-look-inside.html) For the dock, there is a png file: /System/Library/coreservices/springboard.app/SBDockBG.png, that you can replace with your own dock png.

    You cannot apply your own background or other UI components without winterboard. You can still replace sounds, though.

    The reason winterboard and sbsettings lags the phone so hard is because they both utilize lots of (very precious) iphone memory. When I used winterboard and sbsettings, I could barely play games without them crashing, even after using apps like freememory to clear it out beforehand. Now everything runs silky smooth (well, as much as a non-JB iphone anyway) and games never crash.

    Here's a thread in these forums on this topic: http://forums.macrumors.com/showthread.php?t=590598
     
  9. macrumors member

    Joined:
    Sep 26, 2008
    Location:
    Mumbai
    #9
    even i had same experience

    i jailbroke my 3G and noticed a lag and the phone was noticably slow.

    finally restored the firmware to un-jailbreak it & i am happy with a fast iphone :D
     
  10. thread starter macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #10
    Well thank you, this will help me a lot. One thing, im not Familiar with sshing, how would I start off (I have a laptop running vista)
     
  11. thread starter macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #11
    kill the LAG!!!
    can't wait until 3.0 comes out, i dont even care for the new iphone (well just a little) but damn 3.0 hurry up!!!!!!!!!!
     
  12. macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #12
    If it is lagging, you did it wrong. Redo the jailbreak.
     
  13. thread starter macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #13
    oh it you once again, (let me stop)
    well how the hell do you mess up a jailbreak?
    i know u get errors and you have to redo the whole process of jailbreaking you phone but once you jailbreak your set but what do you mean i jailbroke my phone wrong?
     
  14. macrumors regular

    Joined:
    Aug 2, 2008
    Location:
    Australia
    #14
    Restore, redo the jailbreak and dont install winterboard and lag will greatly decrease.
     
  15. thread starter macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #15
    just for that i'll uninstall witner board.
    i dont care about themes and so on i just wanted the transparent dock
     
  16. macrumors G5

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #16
    Of coarse its going to lag. Something not approved by Apple, hello? Also, mine is responsive, retry your jailbreak.

    ProTip: Use Pwnage not quickpwn.
     
  17. macrumors 6502

    TJRiver

    Joined:
    Jan 14, 2009
    #17
    You took the stock OS, screwed with it and are now complaining because you don't like the results.......

    Give me a break.:rolleyes:

    Jesus says: "Leave the Jesus phone alone!":apple:
     
  18. thread starter macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #18
    I used both same damn thing.
     
  19. thread starter macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #19
    Hmmmmm I feel hatered....
    This isn't a church ceremony so leave it for you Sunday school class.
     
  20. macrumors member

    Joined:
    Apr 10, 2008
    Location:
    Vienna, Austria
    #20
    As mentioned before, stay away from winterboard, sbsettings and perhaps even bossprefs and you should not see any noticeable lag.

    I recently re-jailbroke my phone and have not installed the above mentioned and noticed that the lag is gone.
     
  21. macrumors member

    fuz10n

    Joined:
    Mar 29, 2009
    Location:
    Charlottesville, VA
    #21
    1. download filezilla (http://filezilla-project.org)
    2. download openssh using cydia and restart the phone
    3. make sure your iphone is on the same wireless network as your pc. If you do not have a wireless network, skip to bottom of page.
    4. find out your iphone's IP Address
    5. in filezilla, in the quick connect box, use the ip address you found in step 3 as the hostname, root as the username, alpine as the password, and 22 as the port
    6. you're now ssh'd into the iphone

    You can also use utilities that give you ssh capability (as in, root access to the file system) without having a wireless network. (iPhone Browser is a good one: http://code.google.com/p/iphonebrowser/)
     
  22. thread starter macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #22
    Thnx
     
  23. thread starter macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #23
    so i did a full restore

    and i still have a lag with the stock sms (WTF???) oh im pissed i did a full restore for nothing, yes i restored as a new iphone, so what the hell am i doing wrong?:mad:
     
  24. macrumors member

    fuz10n

    Joined:
    Mar 29, 2009
    Location:
    Charlottesville, VA
    #24
    everybody has lag with the stock sms :( I think it's an issue with the phone having to read message history from a database somewhere. They have recognized it and say they are working on it. Let's hope they fix it in 3.0
     
  25. thread starter macrumors 6502a

    alphatectz

    Joined:
    Nov 20, 2008
    Location:
    New York, NY
    #25
    Yea let's hope it get resolved.
     

Share This Page