Language settings Mac OSX

Discussion in 'Mac Applications and Mac App Store' started by jamesjingyi, Jan 27, 2013.

  1. macrumors 6502a

    jamesjingyi

    Joined:
    Dec 20, 2011
    Location:
    UK
    #1
    After recently buying a new MacBook Air, I have been required (for schoolwork) to type up a Pages document in French. I seem to remember being able to swap between languages using the menu bar however now when I try and swap using that method, it changes the q to an a and vice versa which it didn't do on my previous Mac. It also seems to still keep the dictionary in English on the document so I cannot spellcheck my words....
    I've tried googleing it to no avail. Please help!

    N.B Old MacBook was on osx 10.7 and current is on 10.8
     
  2. svenr, Jan 27, 2013
    Last edited: Jan 27, 2013

    macrumors regular

    Joined:
    May 6, 2003
    #2
    If by dictionary, you mean the spell checker: Select your text or the entire document, right-click (Ctrl-click on one-button mouse) on selected text, go Spelling and Grammar -> Show Spelling and Grammar, in the window that pops up select Francais from the pull-down menu on bottom.

    If you mean the actual Dictionary app that has word definitions, sorry, I think that comes pre-installed only in English, although you can install user dictionaries for additional languages.

    With the keyboard switch menu, is your problem that you have a US keyboard but you need to type French accents and therefore want to use a French keyboard layout? French keyboards have certain letters in different places as you discovered, so if you switch the keyboard layout that's what you get.

    If it's not for the accents, then why not simply type with your English keyboard as is? I don't speak French, so not sure how many accents there are, but if it's few, you can use certain key combos on the English keyboard to produce them, e.g. Opt-e gives you an [´] and if you follow that right away with a letter that can take that accent, e.g. an [e] you get é.

    If that gets too impractical because there are too many, then one other option might be to try the Canadian-French keyboard layout. Maybe that matches your physical keys better, IDK but worth a try: System Preferences -> Language & Text -> Input Sources -> check Canadian French CSA. That will add it to the keyboard switch menu.
     

Share This Page