Left4dead 2 and Magic Mouse

Discussion in 'Mac and PC Games' started by whodareswins, Jul 27, 2011.

  1. whodareswins, Jul 27, 2011
    Last edited: Jul 27, 2011

    macrumors regular

    Joined:
    Jul 12, 2011
    #1
    I started playing left4dead 2 today on my iMac with the magic mouse. I love the game, however, with the touch sensitive mouse it sometimes scrolls through the weapons at the most inconvenient times.

    I use q to switch but is there a way to disable the scrolling switch?
     
  2. macrumors 6502a

    PowerGamerX

    Joined:
    Aug 9, 2009
    #2
    Go into Options, Edit Keys and Buttons, scroll down to combat, and clear the Next Weapon/ Previous Weapon.
     
  3. thread starter macrumors regular

    Joined:
    Jul 12, 2011
  4. Huntn, Jul 28, 2011
    Last edited: Jul 28, 2011

    macrumors G3

    Huntn

    Joined:
    May 5, 2008
    Location:
    The Misty Mountains
    #4
    Do yourself a huge favor and get a 4 button mouse (trackball if you can find a decent one) with scroll wheel. Both Kensington and Logitech have Mac programmable software.
     
  5. thread starter macrumors regular

    Joined:
    Jul 12, 2011
    #5
    Thanks, I may well invest in one. The magic mouse is great, imho, but not so much when it comes to games. Although it certainly isn't bad now I have disabled the mouse scroll.
     
  6. macrumors 6502a

    milbournosphere

    Joined:
    Mar 3, 2009
    Location:
    San Diego, CA
    #6
    Agreed. The magic mouse sucks for gaming. Get a corded Logitech Gaming or MX mouse and you'll be very happy. :)
     
  7. macrumors 6502a

    PowerGamerX

    Joined:
    Aug 9, 2009
    #7
    Yes it sucks, but that doesn't stop me from kicking ass with it :cool:
     

Share This Page