Links in Mail won't open

Discussion in 'Mac Apps and Mac App Store' started by Thomas Veil, Jan 18, 2005.

  1. Thomas Veil macrumors 68020

    Thomas Veil

    Joined:
    Feb 14, 2004
    Location:
    Reality
    #1
    I have e-mail notifications at several job search sites. I do get daily e-mails from them, but one, CareerBuilder, is driving me nuts. None of the links in its e-mails work. If I see a job opportunity I'd like to explore, I can't just click on it and read about it.

    Contextual menus (control-click) don't help. All the menus offer is to check the spelling, font or speech. Option-click brings up bupkus. The links do change color when I click on them, but that's it.

    Why, you may ask, don't I just go to CareerBuilder's main site and look up those same jobs there? Well, I have, and even when I type in the exact job name and the exact city it's in, CareerBuilder's search comes up with nothing. Arrrrgh.

    The only thing I've found that works is to go to each company's own web site, look around the for "career opportunities" link, and then read about the job there. As you can imagine, that's a time-consuming workaround.

    So, is there some setting in Mail I can change? Or is it just that CareerBuilder's site and e-mail notifications are screwed up?
     
  2. Nickygoat macrumors 6502a

    Nickygoat

    Joined:
    Dec 11, 2004
    Location:
    London
    #2
    All the links in emails I get work fine. Is it just CareerBuilder? If it is then it's probably them.
     
  3. therevolution macrumors 6502

    Joined:
    May 12, 2003
    #3
    Does this only happen with CareerBuilder links and emails, or ALL links in any email you get?

    Have you checked that your default browser is properly set? Open Safari, go to Preferences, and verify that the browser you want to use is selected.

    (rant: who the heck decided to specify the system-default browser from within a browser?? Seems like a weird choice. I know it used to be under System Prefs...)
     
  4. Thomas Veil thread starter macrumors 68020

    Thomas Veil

    Joined:
    Feb 14, 2004
    Location:
    Reality
    #4
    To answer your questions, links in other e-mails work fine. And Safari is my default browser.

    Yeah, I suspected it was probably them (CareerBuilder), not me, but it didn't hurt to ask....

    Hard to believe they could go on this long with such a ridiculous problem, though. Think I'll e-mail them and tell them what I think of their "service".

    Thanks for your suggestions, anyway.
     

Share This Page