Lion 10.7.4 PPTP VPN MPPE Issues

Discussion in 'Mac OS X Server, Xserve, and Networking' started by kingsapo, May 13, 2012.

  1. macrumors member

    Joined:
    Jun 10, 2010
    #1
    Hey people,

    I recently upgraded my server from Snow Leopard Server to Lion Server, and updated to 10.7.4. I know Lion Server didn't offer a GUI for PPTP configuration before 10.7.3, but after the update I figured I'd give it a shot. I kinda wish I hadn't.

    I've setup VPN through the Server app, basically leaving all the settings to their default. I'm trying to connect to the server locally, so I know port forwarding isn't the issue. I only want to get PPTP working; since one of the L2TP ports is the same as the Back to my Mac through iCloud port (I think it's 4500 or something), I wanted to go with the PPTP so I could also have Back to my Mac (don't ask why I want both).

    Anyway, the issue is in connecting to the server locally, I get an error in the log file about how MPPE is required, but keys are not available. I know what MPPE is, and even followed the support doc from http://support.apple.com/kb/TS4241, but it didn't help. Client-side, I'm getting the error
    I've copied the log file below. Please let me know if I missed any information; I'm in a bit of a rush and had to type this quickly. Any help is always appreciated. Thanks!

     
  2. thread starter macrumors member

    Joined:
    Jun 10, 2010
    #2
    Well, it's been a few days and with no response I thought I'd look for another solution. I've been trying this software called iVPN, apparently it's like a front-end to OS X's built-in VPN server. Anyway, I disabled the VPN Server from the Server app, turned on iVPN and was VPN-ing from my iPhone over 3G in notime. It's a great app, though it kinda sucks that the server can't do what it's built to do. Since VPN was the big reason I got Server in the first place, I'll probably uninstall it and stick with OS X's built-in file sharing and iVPN.
     

Share This Page