Lion and Diamond USB BVU195

Discussion in 'Mac OS X Lion (10.7)' started by Tochill, Jul 4, 2011.

  1. macrumors newbie

    Apr 13, 2010
    Has anyone been able to get this to work with lion? Once i upgraded, all i see is a blank screen on the monitor plugged into the Diamond USB. The monitor recognizes the connection but its just pumping out a black screen.
  2. macrumors 6502

    Madd the Sane

    Nov 8, 2010
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    Wait for a driver for Lion is the only advice I can give you.
  3. macrumors newbie

    Jul 9, 2011
    Can you post this to Diamond's support? I'll do the same.

    Please let us know if you find a driver that works.
  4. thread starter macrumors newbie

    Apr 13, 2010
    I actually found a solution. If you go to the displaylink web site which makes the drivers they have a beta for lion.
  5. macrumors newbie

    Jul 9, 2011
  6. macrumors newbie

    Mar 22, 2012
    Lag trouble

    Anybody else notice some extreme lag when using this product? I've had a ton of lag in both Windows 7 and OSX Snow Leopard and Lion, but I've scoured the internet and found zero posts of other users reporting lag issues.
  7. macrumors newbie

    Mar 8, 2013
    Lion and Diamond USB BVU195

    I had the same issue with BVU195 and Lion. The monitor was just black and would not work. I called Diamond support and they did not have any solutions. Finally, I upgraded to Mountain Lion, installed the 1.8 DisplayLink drivers and it worked.
  8. macrumors newbie

    Oct 9, 2013
    This is still buggy for me, the driver seemed to help a little bit - but the screen constantly flickers with anything that has changing content. The only thing that seems to help is having that screen available for email where content hardly changes...


    Yes I also have had a lot of lag with this product. Not sure what else I can do...

Share This Page