Lion: Constant (strange) disk activity

Discussion in 'Mac OS X Lion (10.7)' started by srfisher101, Jul 25, 2011.

  1. macrumors newbie

    Joined:
    Jul 30, 2007
    #1
    I've had Lion installed since day one. It spent a lot of time the first day indexing. Now, it seems to be constantly doing some disk activity when nothing else is happening. It stop for about ten seconds, then starts up with about 18 disk activities, then stops for ten seconds. I'm not sure that it's hurting anything, but I've never heard it before Lion. Any ideas?
     
  2. macrumors newbie

    Joined:
    Jul 20, 2010
    #2
    Open up Activity Monitor and see what's happening. You might be able to see what is causing this.
    Applications/Utilities/Activity monitor.

    At least this is a good start.

    Pat
     
  3. thread starter macrumors newbie

    Joined:
    Jul 30, 2007
    #3
    Even stranger...

    Thanks, PatM. I spent about 45 minutes with Activity Monitor, slowly backing things out; some things by canceling them the normal way, others by force quitting the processes. I finally gave up, since nothing seemed to be stopping the goofy disk activity. About ten minutes after I gave up, the activity ceased! And it hasn't reappeared for more than 24 hours. Oh well, at least the annoying sound is gone!
     
  4. Editor emeritus

    longofest

    Joined:
    Jul 10, 2003
    Location:
    Falls Church, VA
    #4
    Hey... I know this is an old thread, but I've had the same exact problem. It ends up just killing the responsiveness of the entire system. Something is pounding on the disk, and Activity Monitor just doesn't show what application is making a lot of disk calls.

    Ideas?
     
  5. macrumors 65816

    Partron22

    Joined:
    Apr 13, 2011
    #5
    Start up Console.app (in 'Utilities'), clear its window display, and wait until your disks misbehave. Disk activity usually generates a console message telling you which process is responsible for the action.
     
  6. Editor emeritus

    longofest

    Joined:
    Jul 10, 2003
    Location:
    Falls Church, VA
    #6
    That's a good idea. Will do.
     
  7. Editor emeritus

    longofest

    Joined:
    Jul 10, 2003
    Location:
    Falls Church, VA
    #7
    Heh... looks like I'm getting a kernel log that says "kernel: IOSurface: buffer allocation size is zero". Someone else already found that this had to do with flash (go figure). I'm still using Flash 10, so I'm updating to Flash 11 and seeing if that helps...

    God Adobe software sucks.
     
  8. macrumors 6502

    Joined:
    Nov 23, 2009
    #8
    I have the same issue and I ran 'sudo fs_usage' at the Terminal prompt to see what was happening. Turns out that OS X Lion will fairly often page out data from virtual memory, even if you aren't running anything. Sometimes it takes a long time to do this, and it makes the hard drive thrash for a while. The strange thing is that under the Disk Activity tab of Activity Monitor, it doesn't register the page outs, while fs_usage clearly states that they are page outs. Anyone have any further insight into what is happening here?
     
  9. macrumors 6502

    johto

    Joined:
    Jan 15, 2008
    Location:
    Finland
    #9
    Im having this same problem. Disk spike every 10 seconds !
    ARGH!

    Nothing seems to stop it for good. It even appears on differend user accounts :(

    Can it be something to do with encryption? ...I have my filevault 2 enabled. Something system wide for sure. Not sure if its somehting i have installed or not :confused:
     

    Attached Files:

  10. macrumors 6502

    Joined:
    Feb 20, 2007
    Location:
    CA
    #10
    did anyone ever figure out what was doing this? I have the same problem now, but under ML...never saw it under Lion
     
  11. macrumors regular

    Joined:
    Jun 23, 2010
    #11
    Could it be related to the local disk snapshots by Time Machine?

    I've also seen degraded overall system performance since upgrading from SL, and while I haven't looked into disk usage activity, the nature of the slowdown I get would be consistent with the OS thrashing the disk.
     
  12. inmania, Feb 24, 2012
    Last edited: Feb 24, 2012

    macrumors newbie

    Joined:
    Feb 24, 2012
    #12
    possible disk activity solution

    You may have already figured this out, but I just happened upon this after resolving on my system, so figured I'd share the fix that worked for me. I noticed elsewhere that someone also had VMware on their Activity Monitor list. In my search, I found that many people were able to resolve the problem by dragging their Bootcamp partitions into the Privacy area of Spotlight (in System Preferences) - Spotlight (more specifically the mdworker function) goes nuts trying to index the Windows partition, which isn't possible since it's closed. So I decided to see if that goes for virtual Windows volumes as well, so I dragged my virtual machine volumes (had an older vmware volume that I haven't tossed yet, plus a newer Parallels volume) into Privacy in the Spotlight settings so they'd be off-limits for indexing, and now my 6-core is flying again, no more constant disk activity bogging it down. So might be worth giving that a try - good luck.
     
  13. macrumors 6502

    ixxx69

    Joined:
    Jul 31, 2009
    Location:
    United States
    #13
    Thank you for this! Worked for me.

    This had been driving me nuts - 20 MB/s reads for hours on end. Added my Boot Camp partition into the Privacy area of Spotlight, and reads immediately dropped to virtually nothing.

    (p.s. works for Mountain Lion as well)
     

Share This Page