Lion Firefox drop down menu scrolling ARGH!

Discussion in 'Mac OS X Lion (10.7)' started by B737, Aug 3, 2011.

  1. B737, Aug 3, 2011
    Last edited: Nov 26, 2012

    B737
    Expand Collapse
    macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #1
    before upgrading tp lion i could scroll within website submenus / drop down menus with no problems... Like a web forum, you click the forum menu and it'll pop open a box to scroll within to to jump to the next subforum.

    before i could do this freely...

    now after upgrading, once i start scrolling within the box, the box disappears! its really frustrating

    does anyone know how to fix for this?
    im already using A Better Touch to bring back page scroll jumping but it didnt resolve the sub menu problem :(
     
  2. B737
    Expand Collapse
    thread starter macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #2
    anyone else having this problem?
    it occurs with firefox, chrome seems to be okay, id like to stick to FF... :confused:
     
  3. B737, Aug 7, 2011
    Last edited: Aug 7, 2011

    B737
    Expand Collapse
    thread starter macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #3
    ive tried running firefox in safe mode it does not fix the issue of webpage drop down menus working properly. they always vanish once i start scrolling with the track pad.

    tried FireFox 6 beta and that had the same issue as well.

    no one else has this problem? im at wits end digging around for solutions...
     
  4. paulsalter
    Expand Collapse
    macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #4
    Just a thought

    As it's happening when you scroll in this boxes, try altering the scroll bars behaviour (always on) just to see if it makes a difference
     
  5. B737
    Expand Collapse
    thread starter macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #5
    thats paul, I made that adjustment in Lion as well, made no change...
     
  6. paulsalter
    Expand Collapse
    macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #6
    just been looking, I have exactly the same issue in FireFox

    using the TrackPad, as soon as I try to scroll, the box vanishes
    seems ok with MacBook track pad

    quite a few options in firefox under about:config for scrolling, but dont really know what i am dong in there
     
  7. B737
    Expand Collapse
    thread starter macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #7
    Mines a 13" early 2011 MacBook Air...
    good call on the config i'll go digging around in there...
     
  8. bcbomb47
    Expand Collapse
    macrumors newbie

    Joined:
    Jul 14, 2010
    #8
    Any luck finding a fix for this? It's super annoying :/
     
  9. B737
    Expand Collapse
    thread starter macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #9
    It's ridiculous. And drives me nuts.

    I'm on the verge of just going back to SL. I wish either FF or apple would address this
     
  10. anotherpaul
    Expand Collapse
    macrumors newbie

    Joined:
    Aug 19, 2011
    #10
    Try to set the msg box to min/doc then click on it.

    I have the problem with the FF preferences dialogue box where I enable/disable javascript as needed. The box would appear without anything with the exception of the red & yellow buttons at the left corner.

    Found that if I click on the yellow to dock the box then recall it, the dialogue becomes "normal"; a pain but it works. Can't be FF 6.0 as it also happened in FF 5.0.

    Not exactly the same situation but it is try & error time.
     
  11. Julius Caesar
    Expand Collapse
    macrumors newbie

    Joined:
    Jun 20, 2011
    #11
    I think I found a solution for this after playing with the scroll settings. Go to Firefox preferences > Advanced > General. Here I have autoscrolling unchecked, smooth scrolling checked, and hardware acceleration checked. I only discovered this a few minutes ago, but I think it works.

    I'm using 10.7 Lion on the latest Firefox which is 6.0.2 right now, but I remember having the same problem in 5.0 also. This is all on the MBP trackpad.
     
  12. Partron22
    Expand Collapse
    macrumors 65816

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #12
    I just tried that, and it fixed the problem for me.
     
  13. B737
    Expand Collapse
    thread starter macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #13
    now you find it!
    i already went back to SL lol!

    when i do go to lion i hope this fixes it :)

    can anyone else confirm?

    thank you for posting this!!
     
  14. ithinkitsnice
    Expand Collapse
    macrumors member

    Joined:
    May 27, 2010
    #14
    FF7 + Lion

    Same problem, this did not fix it for me.

    Happens on both my MacBook and Mac Pro w/ Magic Mouse.
     
  15. Julius Caesar
    Expand Collapse
    macrumors newbie

    Joined:
    Jun 20, 2011
    #15
    The problem came back for me too. I'm surprise more people haven't noticed and come posting here.
     
  16. tyzer
    Expand Collapse
    macrumors newbie

    Joined:
    Jan 14, 2006
    #16
    did anyone ever find a fix for this problem? i have the exact same problem, on my imac and macbook air
     
  17. Azathoth
    Expand Collapse
    macrumors 6502a

    Joined:
    Sep 16, 2009
    #17
    Finally I found some others that have the same problem :-s

    I don't have a solution though...
     
  18. Lee Adama
    Expand Collapse
    macrumors regular

    Lee Adama

    Joined:
    Jul 28, 2011
    Location:
    California
    #18
    i think this is an issue on Firefox's side. I've been using Safari and Chrome with no issues. Safari seems smoother on gestures
     
  19. B737
    Expand Collapse
    thread starter macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #19
    this was the biggest reason i rolled back to SL from Lion. When this gets resolved i will be more open to going back to Lion.

    im surprised this hasnt been resolved yet. its a huge deal esp if you surf a lot of forums. its very frustrating. We shouldnt have to migrate to a new web browser....
     
  20. JimA99
    Expand Collapse
    macrumors newbie

    Joined:
    Jan 31, 2012
    #20
    Easy Firefox workaround?

    FWIW, I found that even though the pulldown disappeared with mouseover in Firefox running under Lion on my MacBook, the up/down arrows allowed me to access the pulldown options.
     
  21. B737
    Expand Collapse
    thread starter macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #21
    i cannot believe this hasnt be resolved yet...

    this is one of the biggest reasons ive rolled back and stayed with SL. i can scroll with the magic pad initially in FF pull-down menus. the up down arrows have always worked for me as well under Lion, its a work around but i wish it would get fixed properly.
     
  22. B737
    Expand Collapse
    thread starter macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #22
    can anyone tell me if this issue has been resolved? im starting to think i should update... but dont want to if there are still firefox features that dont work just right...
     
  23. B737
    Expand Collapse
    thread starter macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #23
    Just a follow up to my thread...
    I upgraded from SL to ML, (i know thats a whole nother thread), but firefox sub menu web scrolling is totally fixed and working normally. whew!

    i dig ML too, so far so good!! love the icloud integration.
     

Share This Page