Lion screen sharing is too polite

Discussion in 'Mac OS X Lion (10.7)' started by mentaluproar, Jul 31, 2011.

  1. macrumors 68000

    mentaluproar

    Joined:
    May 25, 2010
    Location:
    Ohio, USA
    #1
    I use my iMac upstairs to install, uninstall, change, and fix things on the mini downstairs. While I can appreciate the changes made in lion, it's inconvenient when I want to see the actual screen. Not everything I need to do is in the admin account, but in the account everyone in the household uses.

    Is it possible for me to keep this dialog when I try to connect, but to set the mini to allow my machine in without asking for feedback downstairs?
     

    Attached Files:

  2. macrumors regular

    Joined:
    Jun 4, 2011
    #2
    I have the same problem.

    It seems the only way to fix it is to use Apple Remote Desktop instead, or some other similar program.

    Regrettably people have reported having some problem with the latest Apple Remote Desktop.
     
  3. macrumors member

    Joined:
    Jul 20, 2011
    #3
    Try using the Easy Screen Sharing app in the Mac App Store. It works great and is free.
     
  4. macrumors 6502a

    Joined:
    Feb 4, 2008
    #4
    Back to My Mac and LogMeIn (www.logmein.com - which is free for personal use and far more reliable than BtMM) allow you to remote control without "asking for permission" and such. I use LogMeIn to remote control several family systems for support.
     
  5. macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #5
    How are you accessing screen sharing? Because I have never seen this before...I access locally thru finder, and remotely thru safari with ip address.
     
  6. thread starter macrumors 68000

    mentaluproar

    Joined:
    May 25, 2010
    Location:
    Ohio, USA
    #6
    I am accessing this via finder.
     
  7. macrumors newbie

    Joined:
    Aug 5, 2011
    #7
    Figured out the "too polite" problem

    I had the same problem when I upgraded our house full of Macs from 10.6 to 10.7. I don't want to have to hop up and walk to another computer when I want to screen share. No need for Apple's Remote Desktop ($80) or any 3rd party VNC client. Works with the native Finder/ built-in Screen Sharing app/ Apple's EasyScreenSharing app (free from App store).

    In order to bypass the need to actively accept a screen sharing request on the target machine, the key appears to be that the screen sharing request has to be received by the target machine as coming from the user currently logged into the target machine. Simply using Finder to re-connect to said machine as that user is not enough. Clearing and re-populating Keychain entries seemed to do the trick. The following worked for me to get things back to the way they were:

    - Restart the machines in question. There seems to be some residual sharing memory somewhere from previous sharing attempts.

    - On the target machine(s), go to System Preferences/ Sharing/ Screen Sharing/ Allow access for: .... and make sure that access is allowed either for all users, or else under "Only these users:", include either the group "Administrators" or the user that is going to be logged in at the time you want to screen share.

    - On the machine from which you wish to initiate the screen sharing request, launch Keychain Access and under the "login" keychain, sort the entries by Name to find the machine(s)/ user(s) of the target machine(s). In my case - the target machines only have a single user, so the name of the machine and the user are the same. You may see <Username> or <Username>.local entries or both. Delete these keychain entry(ies) and close Keychain Access.

    - From Finder on your originating machine, click on the target machine. It will log you in only as Guest initially. Click "Connect As ..." and enter the name and password of the user that is currently logged in on the target machine. I'm assuming that said user has administrator privileges. Check "Remember this password in my keychain" and Connect. You are now connected for file sharing, logged in as the user on the target machine.

    - Click on "Share Screen ...". Now, instead of the dialogue box asking you if you want to ask to share the screen or start a virtual desktop, you will get a box asking you to enter your name and password. Choose "As a registered user" and again enter the name and password of the user on the target machine, and again be sure to check "Remember this password in my keychain".

    - I had to enter the names and passwords once each for connecting directly from Finder, for connecting via EasyScreenSharing, and for connecting via a <Username>.inetloc file I kept on my machine as a quick shortcut to launch Screen Sharing. Looking back at Keychain Access - it saves a separate entry for each one of these access methods and one for Finder File Sharing. But the net result is the same. Using any of the three approaches launches Screen Sharing and shares the target machine's desktop without need for confirmation.
     
  8. macrumors 68020

    Joined:
    Jul 13, 2008
    #8
    Yeah, now Lion allows access to the different accounts on a machine via VNC, so the account name and password that are used to login are the ticket. For me, it seemed to override the password that you enter when you select options in Sharing pref pane.

    Essentially you end up with a dialog box that looks like the one used for file sharing.

    Rob
     

Share This Page