Little Snitch help please!

Discussion in 'Mac Apps and Mac App Store' started by Miqs, Mar 29, 2013.

  1. Miqs
    Expand Collapse
    macrumors member

    Miqs

    Joined:
    Mar 22, 2013
    Location:
    Bedfordshire, UK
    #1
    I have Little Snitch v2.5.2 and had it for a couple of years now working ok. I now find however that when I have LS active I cannot connect to my server with Safari but can with Google Chrome. Why is this? Can anyone tell me how to get Safari back and set it up so that I can only prevent the couple of dubious apps from calling home but allow everything else to function normally. I thought I had set the prefs up ok but something is wrong!

    [​IMG]
     
  2. justperry
    Expand Collapse
    macrumors 603

    justperry

    #2
    Remove the Safari Rules, then you will get asked again next time and allow all.
     
  3. Miqs
    Expand Collapse
    thread starter macrumors member

    Miqs

    Joined:
    Mar 22, 2013
    Location:
    Bedfordshire, UK
    #3
    No it didn't work as you say. I deleted all the Safari rules and with LS active I tried to connect to the internet via Safari but couldn't and wasn't asked for any permission. I now see that if I try with Chrome also I cannot connect either. Both say there is a "server problem". Then when I disconnect from LS I then try to open Safari and Chrome it is ok. Obviously LS is stopping any internet connection direct, but I can link to the internet via my email messages. So how do I get LS to ask me for permission to connect Safari and Chrome directly? There must be a way. Failing that I guess a re installation of little Snitch and go through all the permissions again. Hopefully not! :(
     
  4. justperry, Mar 29, 2013
    Last edited: Mar 29, 2013

    justperry
    Expand Collapse
    macrumors 603

    justperry

    #4
    Bold is disable?

    You can manually add a rule to allow all traffic in Safari or any other App, if this does not work some other process is blocked.
     
  5. Miqs
    Expand Collapse
    thread starter macrumors member

    Miqs

    Joined:
    Mar 22, 2013
    Location:
    Bedfordshire, UK
    #5
    Thanks. I deleted the "deny connections" in "all applications" and then manually put in rules for Safari and Chrome which seems to have worked and negative rules for the apps that I am suspicious of. Thanks again.
     
  6. justperry
    Expand Collapse
    macrumors 603

    justperry

    #6
    I like Little Snitch but it can give headaches once in a while.

    Good it's solved.
     
  7. Miqs
    Expand Collapse
    thread starter macrumors member

    Miqs

    Joined:
    Mar 22, 2013
    Location:
    Bedfordshire, UK
    #7
    I'll second that! :eek:
     

Share This Page