Locked folders after moving inside SMB shares on Mac

Discussion in 'Mac OS X Server, Xserve, and Networking' started by HackerJL, Feb 11, 2010.

  1. macrumors regular

    Joined:
    Sep 19, 2009
    #1
    I will do the best to explain what is happening here.

    I have a Imac, with a share on it, sharing as user 'Central' with a password. There are many folders, everything works great.

    I have a user that is running xp pro, connects to the Imac, has the share mapped to a drive, authenticating as user Central, with password. Access to everything works great.

    When the XP user makes a folder, anywhere on the share, and then moves it into another folder on the same share. It is now 100% locked. On the Imac, the folder has the ownership of Everyone - no access. I give it appropriate access, and it works after that.

    I have another XP machine, tested - same thing. Its like the umask on folders is buggered, but thats just a hunch.

    Anyone have any ideas?
     
  2. macrumors newbie

    Joined:
    Feb 11, 2010
    #2
    I reported this bug in server version 10.5. As far as I know it was never fixed. It is a pretty serious bug, requiring administrative action to correct a effect of a very common action. Possibly only a small number of systems are affected. The alternative to that is that Apple is not serious about SMB support. I've since abandoned the Apple server in favor of a small NAS.

    If you are running 10.6 and this bug is still present I would not hold out much hope for a fix. If you are running 10.5, well, maybe 10.6 fixes it.

    Tom
     
  3. thread starter macrumors regular

    Joined:
    Sep 19, 2009
    #3
    Not the news I wanted to hear, but interesting nonetheless. Its currently a workstation, and I want to put in 10.6 server to do some other work for us, so we will just have to see.

    Thanks
     

Share This Page