Locked myself out of my external hard drive, please help!

Discussion in 'Mac Basics and Help' started by john_satc, Jun 3, 2006.

  1. john_satc macrumors 6502

    Joined:
    Feb 14, 2005
    Location:
    B'ham Uk
    #1
    in my endless fiddling around with things, I have managed to lock myself out of me external hard drive. I opened the info screen of the drive (apple + i). And under ownership and permissions I changed 'you can' to 'no access'. I am so stupid for doing this, I know! But now I cannot get into them, and I cannot find away to reverse this effect. Please help me, I have so much information stored on them, everything is on them, I have to get them back!
    thanks so much!
    jon
     
  2. eva01 macrumors 601

    eva01

    Joined:
    Feb 22, 2005
    Location:
    Gah! Plymouth
    #2
    if you create another account does it still say "no access" under Cmd + I. In the new account
     
  3. john_satc thread starter macrumors 6502

    Joined:
    Feb 14, 2005
    Location:
    B'ham Uk
    #3
    I just tried this and it will not allow me to change the 'no access' option...im getting really lost now, surely someone can help!
     
  4. yippy macrumors 68020

    yippy

    Joined:
    Mar 14, 2004
    Location:
    Chicago, IL
    #4
    there should be a little lock icon in the permissions pain oh get info (you might have to click the little triangle to expand it). It is most likely showing locked. Clicking it will ask for your admin password and will then allow you to change the permissions back.

    If that doesn't work someone should be able to tell you how to do it in terminal. There is also a program called batchmod that might be able to help you.
     
  5. angelneo macrumors 68000

    Joined:
    Jun 13, 2004
    Location:
    afk
    #5
    You might want to go into terminal and use root access to change the file permissions.
     
  6. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #6
    After looking at
    http://forums.macosxhints.com/archive/index.php/t-10684.html

    Try loading up terminal (in Applications/Utilities), and typing
    'cd /Volumes/' (without quotation marks)
    then type 'chmod 755 <name of disk>' (without quotation marks) should solve the problem.

    If you don't know the name of the disk type 'ls -a' to get the name of every disk,
    after you have tyed 'cd /Volumes/'

    --EDIT--

    If the drive is MS-DOS (or FAT 32) formatted you should set the permissions with 'chmod 777 <name of disk>' (without quotation marks) as Windows cannot cope with advanced file permissions.
     
  7. john_satc thread starter macrumors 6502

    Joined:
    Feb 14, 2005
    Location:
    B'ham Uk
    #7

    Hi, I tried this (as shown in picy) but I guess I am doing it wrong...if you can check the picture to see where I am going wrong that would be really helpful. And thank you for your time!
     

    Attached Files:

  8. netdog macrumors 603

    netdog

    Joined:
    Feb 6, 2006
    Location:
    London
    #8
    First type cd /Volumes/

    then hit enter

    on the new prompt line, now type chmod 755 <name of disk>

    BTW, I think he just put the < > in to indicate that this is where the name goes, and not that you need to include the < and > characters when you type (though I could be wrong about that).
     
  9. simon-says macrumors regular

    Joined:
    May 24, 2005
    Location:
    Shreveport, LA
    #9
    First you'll need to `cd /Volumes/` hit enter. Once there `chmod 755 "iBook Back Up"`. Without the backtics of course
     
  10. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #10
    I can help some more from your screenshot. You need to press enter after each command I have quoted, and you need to remove the <>'s as well and replace them with double quotation marks, sorry I didn't really make it clear enough :eek:
    So it should appear as:

    cd /Volumes/
    chmod 755 "iBook Back up"

    the cd command changes to the directory which is hidden and contains disk's attached to your Mac, and the chmod changes the permissions on your disk. The quotation marks are needed as Terminal interprets spaces as gaps between customisable options. :)

    EDIT Beaten to it.
     
  11. john_satc thread starter macrumors 6502

    Joined:
    Feb 14, 2005
    Location:
    B'ham Uk
    #11
    Ok...you are all being so patient with me and I thank you...however, this does not seem to have fixed the programme. For some reason, the external drive is not appearing in the finder, but does appear in disk utility. As shown in the picture below. I ran the terminal programme but that has done nothing, and came up with the error messages.
     

    Attached Files:

  12. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #12
    A space is needed after the cd, it should be 'cd /Volumes' not 'cd/Volumes' which is what you typed.

    cd is the command and /Volumes is a folder so needs a space after it to seperate it from the command ;), that's why you need quotation marks for the second part of the operation, otherwise Terminal would think iBook, Back and Up were all seperate. Sorry if I'm being a bit rambly, I'm trying to explain how terminal works, (though i'm not sure i'm doing a great job really).
     
  13. john_satc thread starter macrumors 6502

    Joined:
    Feb 14, 2005
    Location:
    B'ham Uk

Share This Page