Logitech wireless mouse didn't agree with Win XP on MBP

Discussion in 'Windows, Linux & Others on the Mac' started by jeremy.king, Jun 20, 2006.

  1. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC

    Just wanted to issue a heads up that I tried to use my Logitech Cordless M-RN67 and boy was Windows unhappy. Plugging in the USB reciever, I was greeted with a nice "New Hardware Found" prompt and it thought it was a USB camera :confused: This was promptly followed by a blue screen/reboot. Booting safe mode, I was forced to use an older restore point just to get back up and running. Man! I forget sometimes what a pain Windows can be when you need to recover from failure.

    Anyways, I won't even bother trying again - I think I will just get me a bluetooth mouse sometime soon and just use my wired Mighty Mouse.

    Later all.

    Also, I have a 512 MB chip for a MBP for sale in the Marketplace. If you have a base setup, it would provide a nice speed bump. See linky in sig below. :)
  2. Phatpat macrumors 6502a


    Jun 15, 2003
    Washington DC
    On a related note, I'm having trouble getting my Logitech MX900 to connect. I can see it in Bluetooth Devices, but when I add it I get a message at the bottom right saying "there was a problem with your hardware installation. Your new device may not work properly" and then it doesn't work. I got this mouse to work when I first installed Boot Camp, but I've been having this problem ever since.

Share This Page