Loud, Piercing Sound and Software Update

Discussion in 'Mac Help/Tips' started by hesdeadjim, Jan 16, 2003.

  1. hesdeadjim macrumors regular

    Joined:
    Jul 17, 2002
    Location:
    Austin, TX
    #1
    Hello all. I own a PowerBook G4 800 MHz and I tried to load software update today which is usually no big deal. And, like most of you, I found that it's not working today. On top of that though, my computer makes this loud piercing sound whenever I check from System Preferences. I've never heard this sound before and if I quit System Preferences, it stops. I've tried restarting and it does the same thing. Is this normal, and if isn't is there something wrong with my PowerBook? Thanks for your help.
     
  2. Billicus macrumors 6502a

    Billicus

    Joined:
    Apr 3, 2002
    Location:
    Charles City, Iowa
    #2
    Re: Loud, Piercing Sound and Software Update

    Doesn't sound normal, try using Disk Utility to repair permissions and the hard drive structure. If that doesn't work, try getting a third party disk utility such as DiskWarrior. If all else fails, its still under warranty isn't it?
     
  3. iGod macrumors member

    Joined:
    Aug 16, 2002
    #3
    Are you using Safari? For some reason my Powerbook 800 makes an intermittent high-pitched squeaking noise when I use it. If this is the case, I'm in the same boat as you.
    I just stopped using Safari and everything is fine.
     
  4. DillHarris macrumors member

    Joined:
    Feb 19, 2003
    Location:
    Upstate NY
    #4
    I also have been getting a high pitched whine lately... Except that its not just in Safari... Konfabulator whines when opening, and other apps (software update included) randomly whine. It stops just as mysteriously as it begins (Safari was whining like crazy, and it just stopped, even though I am still using Safari). I have done a fresh install, incl reformatting the HD. Anybody else get any more info on this?
     

Share This Page