M-Audio 49e Not Working

Discussion in 'Mac Apps and Mac App Store' started by edesignuk, Feb 9, 2004.

  1. edesignuk Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #1
    So I just received my 49e keyboard for use with GarageBand :D But the damn thing wont work? Am I missing somthing?
    I have installed the drivers off the CD, rebooted, but GarageBand will not see it :( :mad:

    Some screenies:

    Audio MIDI Setup (Applications > Utilities) Screen 1:
    [​IMG]
    Audio MIDI Setup (Applications > Utilities) Screen 2:
    [​IMG]
    GarageBand Prefs:
    [​IMG]
    System Prefs:
    [​IMG]

    Anyone have any ideas?
     
  2. cpjakes macrumors 6502

    Joined:
    Aug 15, 2003
    Location:
    Buffalo, NY
    #2
    I don't have GB or that particular keyboard, but a few things to check...

    In Audio MIDI Setup, when you "Test Setup" and play, what happens? Do you get any feedback that it is sending data?

    Make sure that your keyboard is broadcasting on Channel 1. Chances are it can only broadcast on Channel 1, but it may have more. A simple app like GarageBand is probably looking on 1 for the signal. It probably ignores anything else.

    If I think of anything else, I'll let you know.

    cpjakes
     
  3. edesignuk thread starter Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #3
    When I do Test Setup, it works. I get a "beep" when I hit any key. There doesn't look to be any channel select.

    This is driving me nuts!
     
  4. cpjakes macrumors 6502

    Joined:
    Aug 15, 2003
    Location:
    Buffalo, NY
    #4
    What about record-enabling the track you want to use in GB? Might be a simple thing that was overlooked... Are you seeing anything on any meters? Volume turned down?

    It either sounds like something very simple or your new keyboard is a lemon.

    cpjakes
     
  5. edesignuk thread starter Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #5
    This is what I get if I try to use a Real Instrument:

    [​IMG]

    How do I record enable a track? :confused:
     
  6. cpjakes macrumors 6502

    Joined:
    Aug 15, 2003
    Location:
    Buffalo, NY
    #6
    As I said, I don't have GB so I can't be certain. But I think you want a Software Instrument, that takes your key information and translates that into the sound of the selected instrument. I'm not sure on the difference between that and a Real Instrument... I would guess that a Real Instrument is something coming in an audio line to record, not a sample playback.

    Record Enabling might be as simple as selecting the track. That seemed to be it in the MWSF demo...
     
  7. erik1975 macrumors member

    Joined:
    Aug 20, 2002
    Location:
    Illinois
    #7
    You defintely want SW instrument, and not real instrument. Real instrument looks for sound on your audio input device, which as I can see you do not have enabled.

    I live in the UK and got my 49e a few weeks ago from the Apple online store. It has worked great since I took it out of the box.

    Did you try to hit any keys when Garageband powered up with just the Grand Piano setting.

    Do you get a blue LED above the + and - buttons on the keyboard?

    If all of this strickes out, you may have some corrupted 'Advanced Functions' settings. I do not have my manual handy, but there must be a way to reset to the defaul Advanced Functions.
     
  8. edesignuk thread starter Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #8
    fellas, thank you very much! It's working now. Looks like as usual, the problem lay between the keyboard and the screen (ie. me! :eek: )

    Thanks again! :)
     
  9. Swampdonkey macrumors newbie

    Joined:
    Feb 19, 2004
    Location:
    London
    #9
    I am having an identical problem. Am sure it is me who is at fault, but I have not yet sorted it. What was it that you were/were not doing? Any advice GRATEFULLY received.:confused:
     

Share This Page