Mac 10.8.3 Admin name and password

Discussion in 'OS X' started by Odedidu, May 5, 2013.

  1. Odedidu, May 5, 2013
    Last edited: May 5, 2013

    macrumors newbie

    Odedidu

    Joined:
    May 5, 2013
    #1
    Hi all,
    i have a strange issue with my MacBook Pro 13.
    It started when some of the application didn't work. For example, i use MplayerX to view video files. Everything was ok, but now if i double click a video file, the MplayerX icon jumps on the dock, and thats it, and it won't play.

    Another weird thing - i can't edit or create playlists in iTunes. Started on the same time.

    Now, when i try to install apps not from Appstore, i get the app_name.pkg can’t be opened because it was not downloaded from the Mac App Store.
    I am trying to allow installation of outside apps, on System Preferences -> Security & Privacy. When im trying to open the make changes lock - i'm being promot to enter admin name & pass. Usually the Name field is already with the name, but now it's empty. I don't know my admin name, and i tried my regular name and pass, those taht i use to login to mac - didn't help.

    Note - under User & Groups, i see my regular user, the current on, with the full name. I tried to enter this name in the admin name field, and also the name of my user as it appears on /Users/user_mac folder - no luck.

    What are my admin credentials, or how to fix this issue? Please advise, thanks.
     
  2. macrumors 603

    justperry

    #2
    Log into your normal account and change parental Controls, allow the other User to Administer the account.

    If you don't have that Name and Password you can't.

    (You are not that kid again from yesterday which "forgot" his admin user name are you. :rolleyes: )
     
  3. thread starter macrumors newbie

    Odedidu

    Joined:
    May 5, 2013
    #3
    @ justperry,

    as i said, a big part of my problem, is that i don't know my admin name & pass.
     
  4. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #4
    The user_name part at /Users/user_name is what you will want to enter in any login box.

    In the Users & Groups pane under your name does it say "Admin"? Are there other accounts listed there also?
     
  5. thread starter macrumors newbie

    Odedidu

    Joined:
    May 5, 2013
    #5
    Right i know, i believe that was always written there, but now suddenly the field is blank, and when i type my /Users/user_name there, and the correct pass it fails to authenticate.

    No it says - Standard.
    There is another account - Guest User - Sharing only, and its grey and not selectable.
     
  6. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #6
    Okay... so you don't have an Admin account at all. Follow this to add a new temp admin account. Then from that account you can give Admin privileges to your existing account from Users & Groups.
     
  7. thread starter macrumors newbie

    Odedidu

    Joined:
    May 5, 2013
    #7
    OK, this was a tough one.

    @ Weaselboy - i followed the tutorial and created a temp admin account, and logged in with it. Surprisingly, this account was also privileged as 'Standard' and i couldn't do any changes with it.

    Then, i decided to re-install my OS, and so i did, via the Restart+CMD+R screen, but after that i still remained with the 2 unprivileged accounts and no admin.

    Finally - i went to the disk utility and completely erased my Macintosh-HD drive and then re-installed the Mac-OS. Now all ok, i have admin, but need to install all apps from the beginning :(

    Thanks anyway, this has been a big pain in my...
    Why would an admin account will disappear like that?
     
  8. macrumors 603

    justperry

    #8
    First, I made that remark in my first post here because just 1 day before there was this kid trying to bypass parental controls and we saw through this, thought you had similar ulterior motives.

    That aside.

    You or someone else might have switched off Admin in the Users & Groups Preference Pane, maybe just a mistake without you realising this, then you forgot the Admin name and password so you couldn't switch it on again.

    Yes, it is a pain and takes some time but luckily it is resolved now.
     
  9. macrumors newbie

    Joined:
    May 13, 2013
    Location:
    OK
    #9
    THIS EXACT SAME THING HAPPENED TO ME! But I CANNOT erase/format my hdd because i need the admin password to do that! the problem started when i installed a new larger HDD and from my new install of osx mountain lion i just get standard accounts from the get go. no admin at all. what can i do if i can't even format the drive?!
     

Share This Page