Mac App Store Won't Download Anything

Discussion in 'Mac Apps and Mac App Store' started by Ericbss7, Oct 23, 2013.

  1. macrumors newbie

    Jul 8, 2013
    I noticed this problem yesterday when trying to download Mavericks. I don't use the Mac App Store too often, but this was the first time it never worked for me. I clicked on the Free Upgrade button next to Mavericks, then clicked Install, then it said Downloading. I went to the Purchased tab, and it shows up, but with a gray Download button. I click it, it fades out, the little spinning symbol shows up next to the 'forward/back' buttons, and then it immediately goes back to gray and still says Download. I tried downloading another free app to no avail.

    I searched around and did these things to try and troubleshoot, with none of them working.

    1. Restarted.
    2. Downloaded updates within Software Update.
    3. Deleted the storeagent in the Activity Monitor.
    4. Entered these commands in the Terminal:
    rm -r ~/Library/Caches/
    rm -r ~/Library/Caches/
    rm ~/Library/Preferences/
    rm ~/Library/Preferences/
    rm ~/Library/Cookies/
    5. Went into iTunes and downloaded the free single of the week to make sure it wouldn't ask me to agree to new terms of service, etc.
    6. Verified my credit card info in my account.

    Does anyone have any other ideas to try? Kind of stumped here.
  2. thread starter macrumors newbie

    Jul 8, 2013
    I also tried resetting permissions. That didn't work either.
  3. macrumors newbie

    Oct 28, 2013
    I'm having the same issue, and I was before Maverick- tried to install Mountain Lion and it never worked. If you find a solution, post because I have no idea either
  4. macrumors newbie

    Nov 13, 2013
  5. macrumors G5


    Jun 27, 2007
  6. macrumors member


    Jul 2, 2011
    Kitsap County, WA
    I ran into something similar when I started the Mavericks install and had to manually sign out from the app store, reboot, sign back in, then go into purchases and tell it to show hidden ones, then was able to install it. May be worth a try?

Share This Page