mac can't read discs

Discussion in 'Mac Apps and Mac App Store' started by theposse, Apr 14, 2005.

  1. macrumors regular

    Joined:
    Mar 31, 2004
    Location:
    TENERIFE
    #1
    I have copied lots of photos using my mac and they all worked fine.....
    Now when i put the same discs in a window opens up saying"mac osx cannot read this disc".
    Can anyone explain to me whats going on.Maybe i have downloaded something i shouldn't have or something.
    Should i reset my computer and start from scratch.
    Would that help ?
    I hope that someone can help me as i'm in a right mess.
    Thanks for any advice
    Scott
     
  2. macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Portland, OR
    #2
    What?

    Maybe you should start from scratch in your explanation...okay, WHAT exactly did you do? You are trying to copy pictures from which computer to which? Which one can't read the discs? What program did you use?
     
  3. thread starter macrumors regular

    Joined:
    Mar 31, 2004
    Location:
    TENERIFE
    #3
    I used the same computer(imac G4) i'm using now to burn the discs.
    I used Finder to burn the discs and i don't think i've done anything to my computer as it reads DVDs and Music CDs no problem.
    I have stored them next to my Amplifier could that be the cause ?..
    Thanks for the response.
    Scott
     
  4. macrumors G4

    Joined:
    Jul 17, 2002
    Location:
    USA
    #4
    I'm thinking maybe that you didn't burn the CD. You only think you did. BTW, placing an optical disk next to a source of magnetic field should have no effect at all.
     
  5. macrumors 68000

    varmit

    Joined:
    Aug 5, 2003
    #5
    To add to this, not saying you didn't burn them, but you put the CD-R or whatever into the drive, told it to use the Finder, dragged your files into, then hit the BURN button. Did you just eject the drive after just dragging the files into the CD? Because dragging them in doesn't burn them, you have to hit the burn button.
     
  6. macrumors 68020

    DavidLeblond

    Joined:
    Jan 6, 2004
    Location:
    Raleigh, NC
    #6
    Look on the bottom of the disc and see if there is anything stored on it. If the whole disc is the same color either a) you filled it up or b) there is nothing on there. If you didn't have 650 mb of stuff to put on it then it probably would be b).
     
  7. thread starter macrumors regular

    Joined:
    Mar 31, 2004
    Location:
    TENERIFE
    #7
    I know for a fact that i have burned the discs because i have used them before and they worked fine.
    I had aniother set of discs that i burned on windows and they used to work fine as well cos all of my screen svaers are of one of them but when i put the same disc in noe it shows that there is a disc there but when i click on it the window it opens has nothing in it saying that the disc has 660.7mbs of space.
    i gave one to a friend of mine who as a mac and it opened up and showed 2 folders but when he clicked on them the beachball came up and it wouldn't eject.
    What is going on...
    They definatley did work before and now they don't so its either the discs or the drive!!!!
     
  8. macrumors 68040

    mduser63

    Joined:
    Nov 9, 2004
    Location:
    Salt Lake City, UT
    #8
    How old are the discs? CD-Rs do go bad eventually, and with some of the cheaper ones, it doesn't take long for them to become unreadable. The fact that you couldn't really open them even on a friend's computer seems to point to the discs being the problem.
     
  9. macrumors 65816

    Sedulous

    Joined:
    Dec 10, 2002
    #9
    How much heat does the amp put out? Your CDs might have gotten partially melted/warped.
     
  10. macrumors G4

    Joined:
    Jul 17, 2002
    Location:
    USA
    #10
    Look, people are trying to help you. The most likely explanation for the lack of data on your disk is that you did not actually burn the disk. The problem may be faulty disks or user error. Either way, you don't have what you need. Claiming that it worked on Windows does not help because it reinforces my theory that you didn't actually complete the process on your Mac.

    It would be helpful if you went through each step and gave us the results of each step. This way, we will know if you are doing everything right or if you are doing anything wrong.

    We want to help you if you will let us.
     
  11. thread starter macrumors regular

    Joined:
    Mar 31, 2004
    Location:
    TENERIFE
    #11
    As i said in my first post...
    MAC OSX CANNOT READ THIS DISC
    Which i presume means that there is indeed something on the disc but my computer cannot read it for some unkown reason.
    i copied most of the discs on windows and they all worked fine as i have put alot of photos on my mac from those discs.
    Now those same discs are seen on the desktop but when i click on them a window opens with nothing in saying 660.7 MBs free space.I tried to burn the mounted disc but it came back saying unable to burn disc which means that they must have something on them!
    I'm talking about 20 discs here which before all worked.
    The ones i burnt using my mac i did the usual.
    Select the files you want burnt and then ,Ctrl, burn disc.
    The mac then burnt the disc and mounted it on my desktop with the files i had burnt.
    I thankyou all for giving me advice.
    The only thing i have done differently is use a program called ONYX to clean up my HD
    Thanks again Scott
     
  12. macrumors 6502a

    rjphoto

    Joined:
    Mar 7, 2005
    #12
    I may have missed something (I went back and re-read the post) but, are you using CD-R or CD-RW disk?

    Also, what are the specs of your Mac and OS?
     
  13. Gee
    macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #13
    Try burning something to a new, blank CD now and see if it comes up with the same error when you reinsert it after burning. If it does, they may be something wrong with your CD drive.

    But it's more likely that there's something wrong with the CDs you're trying to access - as someone said above, CDs tend to 'rot' after a while, especially some of the cheaper versions. Did you write on them with anything that wasn't a felt-tip marker?
     
  14. thread starter macrumors regular

    Joined:
    Mar 31, 2004
    Location:
    TENERIFE
    #14
    I used a magic marker to write on the Memorex CD-Rs but i didn't think that it would have been a problem.
    The thing that i don't understand is the fact the same discs i burn't in iphoto work perfectly fine but the discs i burned using the finder aren't.
    i know for a fact that they used to work 100%...
    Thanks for all the advice.
    Scott
    imac G4,1Ghz
    !7",10.3.9,768 DDR Ram
     
  15. macrumors regular

    Joined:
    Dec 4, 2004
    Location:
    Indiana
    #15
    I could possibily be your DVD player, as my computer's CD-ROM, no longer reads burned discs anymore. But I would not think this would be the case since my CD-ROM is pushing 7 or 8 years and I only started having these problems within the last year or so. On my computer, inserting a CD-R that has been recorded does absolutely nothing. The computer doesn't even think there is a disc inside since I can open the computer tray with the CD-ROM's built-in eject button.

    But I would lean towards your CD-Rs somehow being scratched or dirtied or somehow rendered unreadable. You might check to see if there is any dirt or scratches on the disc, especially towards the inner rings where your optical drive would begin reading the CD.

    The only other thing I can think of but have no proof for my reasoning is that when you used Onxy to clean up your HD, it somehow corrupted some of your indexes and Mac OS X still has those indexes on file but they're broken and this is causing Mac OS X to hiccup and not check your discs itself to see what data is on there. Correcting this would mean tracking down and erasing these indexes. But, I could be delirous and making all this up and I am completely wrong.
     

Share This Page