Mac is opening Apps off another Mac on the network - how do I stop it?!

Discussion in 'macOS' started by Cattywampus_, Oct 24, 2006.

  1. Cattywampus_ macrumors 6502

    Joined:
    Apr 19, 2006
    #1
    Hi,

    At work we have 4 Macs. 2 oldish ones that are used for printing (G3+G4) and 2 newish ones (G5 PowerMac & Intel iMac). I use the iMac and my collegue uses the G5. I am having a problem at the moment where the applications he has installed on his computer are being listed on my computer as apps that can open. And yes, they do open when selected (since the problem arose some file types have defaulted themselves to PPC apps on his Mac which is highly annoying).

    We share all our hard drives on the computers and are connected to each other all the time , and this cannot change as we exchange a lot of files... but how can I stop "Application Sharing" ?

    I need to remove all traces of his Applications on my computer.

    NB : Another example is when i right click on a Html file, and go to Open With, I have options for Safari on my computer , and then an old version of Safari on his Mac. (He still uses Panther).
     
  2. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #2
    Are you using the Dock to open apps? Or just via the file icons in your Finder?
     
  3. Cattywampus_ thread starter macrumors 6502

    Joined:
    Apr 19, 2006
    #3
    Right Just messed with it,

    When I disconnect my shares to his hard drive, the options in "Open With" disappear.

    How can I get the computer to refuse to open up applications up over the network from his computer?
     
  4. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #4
    I wonder if it's Spotlight related, in that Spotlight is finding applications on his disk and adding them to your database. Whilst his disk is mounted on your Mac, go into Spotlight preferences and exclude his Applications folder.
     
  5. Cattywampus_ thread starter macrumors 6502

    Joined:
    Apr 19, 2006
    #5
    Both, but I know for certain all my dock icons are pointing to Apps on my computer.

    [​IMG]

    This is the open with menu I get when I click a JPG. Applications like Fireworks, Flash MX, Opera etc are all Apps that are on his computer- ive never installed them on mine. You can also see the different version numbers for Safari and Preview etc.

    when I drop the share to his hard drive, they disappear! Anyone know a solution?
     
  6. telecomm macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #6
    Since you're sharing boot drives, I doubt there's any way to stop this behaviour. Someone might know more about this than I do (which is more than likely :eek: ), but I don't think there's any way to prevent the running of applications located on a mounted drive.

    One thing that might help is that, as far as my experience goes, the apps listed in your own Applications folder are given priority in the list you get in "Open with...". So, if two version of program X appear, using the first one should ensure that you run only apps on your own computer. Since the other computer is running panther, that helps too. As far as file associations getting messed up, this you can sort out manually by changing the default application for those file types.

    The best solution would probably be to create a separate partition for the boot drives on each of your computers, and avoid sharing those (or simply stop sharing the boot drives).
     
  7. Cattywampus_ thread starter macrumors 6502

    Joined:
    Apr 19, 2006
    #7
    Hi,

    I won't let me add his Apps folder. I've tried adding the w hole hard drive to spotlight exlude list as well but it wont do it. Doesnt give an error, just doesnt add it.

    Tried unticking Applications as well in spolight search place but still didnt solve it.
     
  8. Cattywampus_ thread starter macrumors 6502

    Joined:
    Apr 19, 2006
    #8

    Hmm I'm not 100% convinced. See, the G4 with Panther that is also in the office (used to be my old Machine before i got the iMac) doesnt cause this problem. I connect to the boot-drive of that machine and none of its Applications show up. Could this be a setting on his computer that is telling other Mac's on the network that it can use its Applications?

    If so what setting!? :)
     
  9. telecomm macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #9
    Yeah, I'm not 100% convinced either. :D

    After having a quick look around the System Preferences, what about the Sharing option (in the services section) called "Remote Apple Events"? I'm pretty sure this is disabled by default, but perhaps it's worth a look anyway.
     
  10. Cattywampus_ thread starter macrumors 6502

    Joined:
    Apr 19, 2006
    #10
    God!!!!

    Remote Events didn't do anything. However.

    I went into the Applications folder on my G4 (that I wasn't get any trouble from). Now when that drive is selected it is showing up all the Applications available on that computer!

    I cannot believe this. This must be something that just "happens". Very annoying. :(

    There must be a solution!
     
  11. Queso macrumors G4

    Joined:
    Mar 4, 2006
  12. Cattywampus_ thread starter macrumors 6502

    Joined:
    Apr 19, 2006
  13. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #13
    OK. How about you mount the other Mac's drive at a different mount point, one that doesn't include his Applications directory? The problem seems to be that you are mounting his entire drive.

    This tip on MacOSXHints.com might do the business for creating a more suitable AFP share.
     
  14. Cattywampus_ thread starter macrumors 6502

    Joined:
    Apr 19, 2006
    #14
    Hmm it could be quite difficult doing that as there are lots of folders on the root of the drive that I access.

    I just tried opening the Applications folder on my iMac from my G4 and it does the same on that (the Panther machine). So it seems that its an OSX built in thing that you can share apps (I seem to recall OS9 had an option to turn this on and off!). Its possibly the worst feature of OSX!.

    I have had an idea that perhaps I could set the permissions on his Applications folder so that only his username can read and write and everyone else cannot even read?
     
  15. telecomm macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #15
    That would get messy—for instance, someone creates a new account on that computer and then can't use any applications, etc.

    It looks like you'll really have to start taking important shares out of the root directories and set up a better sharing system. I don't think it was ever intended that an entire boot drive be used as a shared volume.
     
  16. Cattywampus_ thread starter macrumors 6502

    Joined:
    Apr 19, 2006
    #16
    Beh think we're gonna have to live with it. One of the guys is a pain in the arse and his filing system is just er bad. Files all over the place and copies of files that he calls "backups" all over (hence why we need to share the whole drive).

    I know full well he wouldn't go through it all and sort it cause the problem doesnt bug him as much as it bugs me.


    If anyone does have any more ideas then please let me know! As far as I can tell all I really need to do is to find some way of the Applications folder being shared. There must be someway of blocking that folder!
     
  17. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #17
    Yeah, in OS 9 I know there was an option to turn on/off "Application Sharing". I guess it's gone, unless it's just hidden somewhere. You could ask him (assuming you're not just using his login) to set the permissions on the Applications folder to exclude your username. That way, at least the application wouldn't open if you clicked it, even if it might still show up in the list (I don't know if it would, I've never seen that issue). Worth a try.

    jW
     
  18. Cattywampus_ thread starter macrumors 6502

    Joined:
    Apr 19, 2006
    #18
    There's no way to exlcude a user permission wise like that. :/
     
  19. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #19
    Actually, there is, though you might have to use Unix commands to do so. If nothing else, just set it up not as an admin account, but a restricted user (Standard with options turned on) and deny access to all programs. That's probably the easiest option, though a little limited with regards to other functionality. The best solution would be to set that user up in a different group, and set the permissions for "Others" on the Applications folder to No access, but like I said, that might require use of the Terminal and Unix commands.

    jW
     
  20. telecomm macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #20
    This won't work in the situation in question, since the user for whom we want to restrict access doesn't even have any account on the other system, he's simply mounted the entire drive.
     

Share This Page