Mac Mail/Gmail IMAP problems

Discussion in 'Mac Apps and Mac App Store' started by Papa Goose, Jun 21, 2013.

  1. macrumors newbie

    Joined:
    Apr 10, 2011
    Location:
    Switzerland
    #1
    Hi all,

    We run gmail (IMAP) as our email provider and access it using mail on our 27"iMac, macbook pro, ipads and iphones. The settings on all the devices are exactly the same, and all behaved in the same way... until recently. The mbp is not affected at all, but the iMac, phones and iPads are getting multiple mails appearing in the Google Mail All mail folder (not the mailboxes folder), 1 is the actual email, the others seem like drafts. I deleted the drafts and after 5 mins or so they all re-appear in the all mail folder. That folder has ballooned from 5 or 6,000 as I know it acts as a kind of archive, but just now is sitting at 39,642, and 2942 unread...which is simply impossible.

    Anyone have any tips on what would cause this and how to fix it, and why it's not affecting the mbp just everything else.
     
  2. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #2
    Go to this screen at gmail.com and uncheck show in IMAP for All Mail.

    This will also cut the GMail storage space used on your iMac by half since all mail is just a dup. of the other folders/labels.

    [​IMG]
     
  3. macrumors regular

    Joined:
    May 19, 2003
    Location:
    Miami, FL
    #3
    You might want to uncheck "store draft messages on the server" in Mail on your iMac.

    I have experienced a persistent behavior in gmail where every word of a draft (when it is set to be stored on the server) becomes its own email message. That then becomes part of your All mail on the iOS devices.

    Are the drafts you mention fragments of longer emails you have typed?

    If you really like having email drafts available on all your devices, this will break that, but it will solve the problem.

    I've adapted so that my iOS devices and web version of gmail share a drafts folder and my Mac has its own.
     
  4. thread starter macrumors newbie

    Joined:
    Apr 10, 2011
    Location:
    Switzerland
    #4
    Thanks fellas, that has solved the problem of the duplicates... just gotta clear 35,000 'draft' mails from the all mail folder. Is there a way going forward to configure Mac/gmail so that if I delete in mac mail it also deletes in the gmail all mail folder?
     

Share This Page