Mac Mail Is Out Of Control

Discussion in 'Mac Apps and Mac App Store' started by kathyricks, Feb 12, 2013.

  1. macrumors regular

    Joined:
    Nov 26, 2012
    Location:
    Salem, OR
    #1
    How can I stop Mac Mail from doing this for 1-2 minutes everytime I launch the program? How can I permanently prevent this from ever happening again? http://www.youtube.com/watch?v=e7i__qOdRu8

    And why does Mail pause for 1-2 minutes before sending a message in Snow Leopard (10.6.8)? Thanks.
     
  2. macrumors 6502

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #2
    It looks like it might be Notifications. Mine show up at the top of my screen. Open System Preferences > Notifications. You can select to only show 5 or just drag mail to the bottom below "not in Notification center".

    Also open Mail Preferences under Mail in the Menu bar. select General. New message notifications > You could select contacts to only see those messages show up in notifications.
     
  3. thread starter macrumors regular

    Joined:
    Nov 26, 2012
    Location:
    Salem, OR
    #3
    Thanks for trying, but when I open System Preferences there is nothing I see that says "Notifications". And when I open Mail Preferences and Select General there is nothing I see that says "New Message Notifications"
     
  4. macrumors member

    Joined:
    Feb 7, 2013
  5. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #5
    You won't have Notifications since you are on Snow Leopard.

    Am I seeing what I think in that video... every message is appearing in the Dock?? Do you maybe have a Mail rule or extension that is saving messages somehow?
     
  6. macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #6
    OK - so what happened here is somebody has a habit of minimizing emails into the dock instead of closing them. So, every time you relaunch the program, it's repopulating the dock with the messages you have minimized there, which is taking all that time.

    What you need to do it launch mail and remove these messages from the dock one by one (by dragging them out of the dock).

    The next important step is to understand why this happened, and change your behavior to avoid it in the future. Minimizing a file to the dock is not the same as closing a file. (Forgive me if you know this, not meaning to insult) When you hit the little red button it closes an email, but if you hit the little yellow one it just adds it to your dock.

    ----------

    On the other outgoing Mail issue, I remember troubleshooting this but I am not 100% sure what the solution was. Here are a few things to try:

    http://onsoftware.en.softonic.com/how-to-fix-mail-problems-in-snow-leopard
     
  7. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #7
    Hah... nice catch. I never would have guessed that. So if you minimize several messages, even after quitting Mail app they will reappear in the Dock like in the OP's video?
     
  8. macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #8
    Yes, Mail saves your state on quit. For instance I keep a few messages opened separately from the main message window just so I don't forget them. Others keep them in their dock so they know to address them. Although I've seen that habit get out of control here in my office. :)
     
  9. thread starter macrumors regular

    Joined:
    Nov 26, 2012
    Location:
    Salem, OR
    #9
    Yes, it seems like every or most messages I open and read somehow end up in the dock and then when I am finished reading all the new incoming messages and quit the Mail program these read messages temporarily dissappear from the dock - but then they reload again the next time I launch the Mail program to read new messages.

    I had this same problem under Tiger. I do not know what you mean by "Mail rule" or "extension". I would just like to know how to stop the messages from reloading themselves in the dock. And since I am not a geek, I need someone to explain how to fix this problem with using geek terminology like "if you minimize messages". I do not know what "minimize messages" means. I just click on a message to read it, then click on the next, then the next and then quit the program, although of course if I frequently respond to messages too. Thanks again for any further assistance you may have to offer.
     
  10. macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #10
    • Launch Mail
    • Drag messages out of the Dock
    • Stop minimizing messages to the Dock. (Close them with the red button, not the yellow one)
     
  11. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #11
    It sounds like somehow you are "minimizing" individual messages into the dock as you read them. By "minimize", I refer to shrinking or collapsing the window down into the Dock rather than closing the window. One would ordinarily click the red bubble at the top left to close a window, and it sounds like you are minimizing instead. You can minimize a window by either clicking the yellow bubble, or by hitting the keys command-m, or by double clicking the title bar of the window.

    This video shows a window being minimized. Note in the same video the narrator changes a setting the the Dock pane of System Preferences that makes minimized windows collapse into the app icon (the Mail icon on the dock in your case) rather than to the side of the dock like you are seeing. Look in that Dock settings pane and checkmark where is says "Minimize windows into application icon" and the messages should collapse into the Mail icon in the Dock instead of next to the trash like you are seeing.

    Or, you can follow Darth's tip to get rid of them.
     
  12. thread starter macrumors regular

    Joined:
    Nov 26, 2012
    Location:
    Salem, OR
    #12
    Thanks Weaselboy and Darth. I now understand what I was doing wrong. Problem solved thanks to you both!
     
  13. thread starter macrumors regular

    Joined:
    Nov 26, 2012
    Location:
    Salem, OR
    #13
    I'm still having this infuriating problem: http://www.youtube.com/watch?v=e7i__qOdRu8 because it it NOT intuitive for me to have to reach all the way over to the red dot to close a mail message window. I always end up closing the window with the yellow dot. Therefore Mac Mail continues to be the biggest piece of JUNK imaginable. Clearly it was designed by a former Microsoft employee who gets a kick out of subjecting the public to electronic torture.
     
  14. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #14
    What you might try (and find more intuitive) is hit the command-w keys (both at the same time) to close a mail message window. I find it much much faster then moving my hand over to the mouse then navigating to the stop lights. Hope this helps.
     

Share This Page