Mac mail sending emails from wrong account

Discussion in 'Mac Basics and Help' started by adamonit, Jun 13, 2011.

  1. macrumors newbie

    Joined:
    Jun 13, 2011
    #1
    Hi everyne!

    firstly thanks for even reading this, it's nice to be heard :)

    I'm running Mac OS X 10.6.7
    Mail 4.5 version

    I have 2 accounts, 1 for work, and a gmail for spamming my friends :D

    So, there is this work account account giving me trouble:

    1. I can only send emails from it when I'm in office, at home or elsewhere I can only receive emails to it, not send.

    2. It started a couple of days ago with not allowing me to send emails from it, even when I'm in office!
    After 10-15 min of searching it started working fine. But this morning again, I can't send emails from it!

    But what is worse: imagine I compose an email and send it to my gmail for check, it flies off Ok, but in gmail.com inbox I see: from "WORK NAME" aaaaa@GMAIL.COM !!!

    WHY??

    and in the sent box it tells me that my email has been sent from work account

    but when I checked in gmail.com On-line (not on my MAC) it gives me: sent from @gmail.com :eek::(

    Can you guys help me out? Thank you!
     
  2. satcomer, Jun 13, 2011
    Last edited: Feb 20, 2013

    macrumors 601

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Open Mail, go to Mail's Preferences, then in Mail's Preferences select the 'Composing' tab. Then put a checkmark in the box for 'Automatically complete address'. The go to Mail's menu item 'Window' and select "Previous Addresses" and delete the ones you don't want.

    Then open Mail's Preferences again and select the 'Accounts' tab. Then select your GMail account and in the right hand pane look at the 'Out going Mail Server (SMTP) and check it's settings when using GMail. Also check the 'Composing' tab again and check all the settings to where you want the settings to say in the Compose window.
     
  3. thread starter macrumors newbie

    Joined:
    Jun 13, 2011
    #3
    Hi satcomer, thanks for your reply
    the issue is with sending from work server, not receiving..

    it didn't help though i tried
     
  4. macrumors 601

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    Are you try to have the email go through the work email server or look like it came from your email email account?
     
  5. thread starter macrumors newbie

    Joined:
    Jun 13, 2011
    #5
    earlier this morning it appeared as though emails arrive from my personal account, now the emails (work emails) don't go through at all..
     
  6. macrumors 601

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #6
    Sounds like server problems. In Mail select the menu item 'Window' and select "Connection Doctor". Use this to see what the server is telling your Mac Mail and trace down the problem.
     
  7. thread starter macrumors newbie

    Joined:
    Jun 13, 2011
    #7
    all servers perfectly working!
    but the problem is still there...
     
  8. macrumors 601

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #8
    So did you go into Mail's Preferences, Accounts and select the SMTP server list and see if you have it setup to use your work email server?
     
  9. r0k
    macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #9
    @satcomer you have hit on the key...

    Make sure your gmail smtp settings have a check mark for "only use this smtp server" and you should be good to go. I suspect that your work email server is "doing something" to your outgoing messages but if you use gmail's server, and you log in with your gmail account and password, it should let you "send as" whoever you want including your gmail email and even your work email. This is because a lot of users let gmail "aggregate" several accounts and they went to "send as" the person the email was addressed to rather than their gmail account name. This is something mobile me doesn't support very well but gmail does support.
     
  10. thread starter macrumors newbie

    Joined:
    Jun 13, 2011
    #10
    satcomer, I have several emails and all are using their proper servers..

    it's just this last email (I added it a week or so ago) that's giving me troubles.

    r0k, I'm not sure what you mean, as I said:

    each email account is using its own server,
    everywhere "use only this server" is checkmarked

    I am connected to this server because I can see files on it, create folders etc

    it's just that my emails are stuck and don't go through.

    Do you guys want to see what Connection Doctor talls me? :D

    READ Jun 13 18:20:50.203 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.gmail.com -- port:995 -- socket:0x11dba2210 -- thread:0x118e9e410
    +OK Welcome.

    WROTE Jun 13 18:20:50.215 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:smtp.mastermail.ru -- port:465 -- socket:0x118fe08d0 -- thread:0x1167ee240
    AUTH PLAIN (*** 52 bytes hidden ***)

    WROTE Jun 13 18:20:50.233 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.gmail.com -- port:995 -- socket:0x11dba2210 -- thread:0x118e9e410
    QUIT

    READ Jun 13 18:20:50.259 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:smtp.mastermail.ru -- port:465 -- socket:0x118fe08d0 -- thread:0x1167ee240
    235 2.0.0 OK

    WROTE Jun 13 18:20:50.300 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:smtp.mastermail.ru -- port:465 -- socket:0x118fe08d0 -- thread:0x1167ee240
    QUIT

    READ Jun 13 18:20:50.398 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.gmail.com -- port:995 -- socket:0x11dba2210 -- thread:0x118e9e410
    +OK Farewell.

    CONNECTED Jun 13 18:20:52.226 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.dominterier.ru -- port:993 -- socket:0x11d012cf0 -- thread:0x11db70580

    READ Jun 13 18:20:52.347 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.dominterier.ru -- port:993 -- socket:0x11d012cf0 -- thread:0x11db70580
    * OK IMAP4 ready

    WROTE Jun 13 18:20:52.375 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.dominterier.ru -- port:993 -- socket:0x11d012cf0 -- thread:0x1167ee240
    1.146 CAPABILITY

    READ Jun 13 18:20:52.396 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.dominterier.ru -- port:993 -- socket:0x11d012cf0 -- thread:0x1167ee240
    * CAPABILITY IMAP4 IMAP4rev1 UIDPLUS AUTH=PLAIN
    1.146 OK completed

    WROTE Jun 13 18:20:52.419 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.dominterier.ru -- port:993 -- socket:0x11d012cf0 -- thread:0x118e64960
    2.146 LOGIN adam@dominterier.ru ********

    READ Jun 13 18:20:52.442 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.dominterier.ru -- port:993 -- socket:0x11d012cf0 -- thread:0x118e64960
    2.146 OK LOGIN Ok.

    WROTE Jun 13 18:20:52.465 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.dominterier.ru -- port:993 -- socket:0x11d012cf0 -- thread:0x118e64960
    3.146 CAPABILITY

    READ Jun 13 18:20:52.488 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.dominterier.ru -- port:993 -- socket:0x11d012cf0 -- thread:0x118e64960
    * CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE
    3.146 OK CAPABILITY completed

    WROTE Jun 13 18:20:52.512 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.dominterier.ru -- port:993 -- socket:0x11d012cf0 -- thread:0x118e64960
    4.146 LIST "" ""

    READ Jun 13 18:20:52.534 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.dominterier.ru -- port:993 -- socket:0x11d012cf0 -- thread:0x118e64960
    * LIST (\Noselect) "." ""
    4.146 OK LIST completed

    WROTE Jun 13 18:20:52.558 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:pop.dominterier.ru -- port:993 -- socket:0x11d012cf0 -- thread:0x118e64960
    5.146 LOGOUT

    CONNECTED Jun 13 18:20:54.074 [kCFStreamSocketSecurityLevelNone] -- host:smtp.gmail.com -- port:587 -- socket:0x117a79a40 -- thread:0x118ed9040

    READ Jun 13 18:20:54.128 [kCFStreamSocketSecurityLevelNone] -- host:smtp.gmail.com -- port:587 -- socket:0x117a79a40 -- thread:0x118ed9040
    220 mx.google.com ESMTP n13sm1131968fab.22

    WROTE Jun 13 18:20:54.161 [kCFStreamSocketSecurityLevelNone] -- host:smtp.gmail.com -- port:587 -- socket:0x117a79a40 -- thread:0x118ed9040
    EHLO [192.168.0.30]

    READ Jun 13 18:20:54.216 [kCFStreamSocketSecurityLevelNone] -- host:smtp.gmail.com -- port:587 -- socket:0x117a79a40 -- thread:0x118ed9040
    250-mx.google.com at your service, [92.39.128.162]
    250-SIZE 35882577
    250-8BITMIME
    250-STARTTLS
    250 ENHANCEDSTATUSCODES

    WROTE Jun 13 18:20:54.238 [kCFStreamSocketSecurityLevelNone] -- host:smtp.gmail.com -- port:587 -- socket:0x117a79a40 -- thread:0x118ed9040
    STARTTLS

    READ Jun 13 18:20:54.292 [kCFStreamSocketSecurityLevelNone] -- host:smtp.gmail.com -- port:587 -- socket:0x117a79a40 -- thread:0x118ed9040
    220 2.0.0 Ready to start TLS

    WROTE Jun 13 18:20:54.521 [kCFStreamSocketSecurityLevelTLSv1SSLv3] -- host:smtp.gmail.com -- port:587 -- socket:0x117a79a40 -- thread:0x118ed9040
    EHLO [192.168.0.30]

    READ Jun 13 18:20:54.575 [kCFStreamSocketSecurityLevelTLSv1SSLv3] -- host:smtp.gmail.com -- port:587 -- socket:0x117a79a40 -- thread:0x118ed9040
    250-mx.google.com at your service, [92.39.128.162]
    250-SIZE 35882577
    250-8BITMIME
    250-AUTH LOGIN PLAIN XOAUTH
    250 ENHANCEDSTATUSCODES

    WROTE Jun 13 18:20:54.602 [kCFStreamSocketSecurityLevelTLSv1SSLv3] -- host:smtp.gmail.com -- port:587 -- socket:0x117a79a40 -- thread:0x118ed9040
    AUTH PLAIN ************************

    READ Jun 13 18:20:55.133 [kCFStreamSocketSecurityLevelTLSv1SSLv3] -- host:smtp.gmail.com -- port:587 -- socket:0x117a79a40 -- thread:0x118ed9040
    235 2.7.0 Accepted

    WROTE Jun 13 18:20:55.160 [kCFStreamSocketSecurityLevelTLSv1SSLv3] -- host:smtp.gmail.com -- port:587 -- socket:0x117a79a40 -- thread:0x118ed9040
    QUIT

    CONNECTED Jun 13 18:21:02.035 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11c902870

    READ Jun 13 18:21:02.275 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11c902870
    * OK The Microsoft Exchange IMAP4 service is ready.

    WROTE Jun 13 18:21:02.301 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11db70580
    1.145 CAPABILITY

    READ Jun 13 18:21:02.326 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11db70580
    * CAPABILITY IMAP4 IMAP4rev1 AUTH=NTLM AUTH=GSSAPI AUTH=PLAIN UIDPLUS CHILDREN IDLE NAMESPACE LITERAL+
    1.145 OK CAPABILITY completed.

    WROTE Jun 13 18:21:02.349 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11da76bb0
    2.145 AUTHENTICATE NTLM

    READ Jun 13 18:21:02.370 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11da76bb0
    +

    WROTE Jun 13 18:21:02.392 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11da76bb0
    TlRMTVNTUAABAAAAB4IIAAAAAAAAAAAAAAAAAAAAAAA=

    READ Jun 13 18:21:02.413 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11da76bb0
    + TlRMTVNTUAACAAAACAAIADgAAAAFgokCtthMTE0Fuw0AAAAAAAAAAMoAygBAAAAABgGxHQAAAA9NAFMAQgBPAAIACABNAFMAQgBPAAEAGABXAEkATgBNAEEASQBMAEMAQQBTADEAMQAEACQAbQBzAGIAbwAuAG0AYQBzAHQAZQByAGgAbwBzAHQALgByAHUAAwA+AFcASQBOAE0AQQBJAEwAQwBBAFMAMQAxAC4AbQBzAGIAbwAuAG0AYQBzAHQAZQByAGgAbwBzAHQALgByAHUABQAkAG0AcwBiAG8ALgBtAGEAcwB0AGUAcgBoAG8AcwB0AC4AcgB1AAcACADBRpEe1SnMAQAAAAA=

    WROTE Jun 13 18:21:02.436 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11da76bb0
    TlRMTVNTUAADAAAAGAAYAEAAAAD6APoAWAAAAAAAAAAAAAAANgA2AFIBAAAcABwAiAEAAAAAAAAAAAAABYIIAK63Vclyc7oJAUnoJlmTuWu+JBtW7AsRONs+BSQYxXYEmuAORVPHwSYBAQAAAAAAAHArwB/VKcwBviQbVuwLETgAAAAAAgAIAE0AUwBCAE8AAQAYAFcASQBOAE0AQQBJAEwAQwBBAFMAMQAxAAQAJABtAHMAYgBvAC4AbQBhAHMAdABlAHIAaABvAHMAdAAuAHIAdQADAD4AVwBJAE4ATQBBAEkATABDAEEAUwAxADEALgBtAHMAYgBvAC4AbQBhAHMAdABlAHIAaABvAHMAdAAuAHIAdQAFACQAbQBzAGIAbwAuAG0AYQBzAHQAZQByAGgAbwBzAHQALgByAHUABwAIAMFGkR7VKcwBAAAAAAAAAABpAG4AZgBvAEAAYwBlAHIAYQBtAGkAYwBzAC0AdABlAHIAcgBhAGMAbwB0AHQAYQAuAHIAdQBtAHkALQBNAGEAYwAtADUALgBsAG8AYwBhAGwA

    READ Jun 13 18:21:02.476 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11da76bb0
    2.145 OK AUTHENTICATE completed.

    WROTE Jun 13 18:21:02.499 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11da76bb0
    3.145 CAPABILITY

    READ Jun 13 18:21:02.521 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11da76bb0
    * CAPABILITY IMAP4 IMAP4rev1 AUTH=NTLM AUTH=GSSAPI AUTH=PLAIN UIDPLUS CHILDREN IDLE NAMESPACE LITERAL+
    3.145 OK CAPABILITY completed.

    WROTE Jun 13 18:21:02.546 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11da76bb0
    4.145 LIST "" ""

    READ Jun 13 18:21:02.568 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11da76bb0
    * LIST (\Noselect \HasChildren) "/" ""
    4.145 OK LIST completed.

    WROTE Jun 13 18:21:02.593 [kCFStreamSocketSecurityLevelNegotiatedSSL] -- host:imap.mastermail.ru -- port:993 -- socket:0x11da04dc0 -- thread:0x11da76bb0
    5.145 LOGOUT
     
  11. r0k
    macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #11
    I see from your connection doctor logs you are using POP. While it might not directly improve the smtp difficulties you are having, I suggest you stop using POP and use IMAP. Take a look at the gmail help for Mail.app 4.0 settings here. When I have had trouble free access to gmail, it has been with clients set up to use IMAP for incoming and include my gmail login name for outgoing email. Notice how the smtp setting isn't simply smtp.gmail.com, it's smtp.gmail.com:somebody@gmail... Also use SSL is checked wherever it is available.

    hope this helps...
     
  12. thread starter macrumors newbie

    Joined:
    Jun 13, 2011
    #12
    Hi r0k,
    thanks a lot but it didn't help either, I just reinstalled the account and it seems to run smoothly.
    Thank you anyway!
    A
     
  13. macrumors newbie

    Joined:
    Feb 19, 2013
    #13
    hey, I realise this thread is quite old, but I had exactly the same problem with my mail, except with two Gmail accounts. When I went into SMTP accounts, there was a problem with one of the passwords, and so it was not connecting. Fixed the password and it went back to normal.
     

Share This Page