Mac malware door creaks open

Discussion in 'MacBytes.com News Discussion' started by MacBytes, May 9, 2005.

  1. macrumors bot

    Joined:
    Jul 5, 2003
    #1
  2. macrumors 6502a

    AtHomeBoy_2000

    Joined:
    Feb 3, 2005
    #2
    Well that's interesting. I have a feeling that Apple will quickly find a way to correct that problem.

    Purhaps require a password to install widgets?
     
  3. macrumors 6502a

    csubear

    Joined:
    Aug 22, 2003
    #3
    The solution is very very very simple. Do not automaticaly copy widgets into your ~/Libary/Widgets. Simple.
     
  4. macrumors 6502a

    mrsebastian

    Joined:
    Nov 26, 2002
    Location:
    sunny san diego
    #4
    anyone wanna take bets when apple will release a fix for this ;)
     
  5. macrumors 6502a

    sorryiwasdreami

    Joined:
    Apr 24, 2004
    Location:
    way out in the sticks
    #5
    Is there a setting for this? If so, can you direct me to it?
     
  6. macrumors 68040

    dornoforpyros

    Joined:
    Oct 19, 2004
    Location:
    Calgary, AB
    #6
    Firefox wins again :D
     
  7. macrumors regular

    Joined:
    Nov 18, 2003
    Location:
    New York, NY
    #7
  8. macrumors 68040

    dornoforpyros

    Joined:
    Oct 19, 2004
    Location:
    Calgary, AB
    #8
  9. macrumors 6502

    Joined:
    Jun 16, 2004
    #9
    Well, my iBook is not affected because its using Panther, and on my iBook and iMac (which is running Tiger) I have auto opening of files disabled after download because honestly it just annoys me. Therefore, problem indirectly solved, no auto widget installations for me :)
     
  10. macrumors 68000

    Phat_Pat

    Joined:
    May 8, 2004
    Location:
    I Live Where I Live
    #10
    I'll give it a week tops.
     
  11. macrumors regular

    Paul O'Keefe

    Joined:
    Jan 23, 2005
    #11
    apple drops the ball

    way to go apple. I think I'll stay away from OS 10.4 for the time being. This is a major oversight and let's face it... screwup.
     
  12. macrumors 6502a

    jayb2000

    Joined:
    Apr 18, 2003
    Location:
    RI -> CA -> ME
    #12
    easy workaround

    As the original site points out, just disable the "Automatically open 'safe' files after download" in Safari preferences.
     

Share This Page