Mac Mini Sleep Issue?

Discussion in 'Mac mini' started by phr0ze, Feb 20, 2013.

  1. macrumors 6502a

    Joined:
    Jun 14, 2012
    Location:
    Columbia, MD
    #1
    I finally turned on Screen Sharing on my Mac Mini so I can manage it from my MacBook while at home. Everything worked great. This morning I tried to connect, but the Mac Mini was not even visible in Finder.

    I had to go all the way to the basement, tap the keyboard, then the mini showed back up in Finder.

    I assumed this was sleep kicking in. I turned off sleep, but prefer not to have to.

    The purpose of the Mini is Media Server.
     
  2. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Do you have "Wake for network access" checked in your Energy Saver preferences?
     
  3. thread starter macrumors 6502a

    Joined:
    Jun 14, 2012
    Location:
    Columbia, MD
    #3
    I do, but having the mini appear in finder is actually before 'wake on access'.
     
  4. macrumors 68030

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #4
    I would assume that the mac can't be asleep in order for it to be visible in Finder. My Mac Mini is also my media server so it's been set to sleep "Never" since day one.
     
  5. macrumors 65816

    lunaoso

    Joined:
    Sep 22, 2012
    Location:
    New England, USA
    #5
    Get an app like WakeOnLan, put in your MAC address and then you can remotely wake it up whenever you want. That's what I do. The Mac has to be in sleep mode and not off though.
     
  6. macrumors 601

    Joined:
    May 21, 2009
  7. macrumors 6502a

    palebluedot

    Joined:
    Jun 29, 2008
    #7
    I'm pretty sure sleep/wake/etc. is TERRIBLE now in ML (and Lion). It's really frustrating as I assume Apple wont issue a fix... but just Google the tons of threads on it. Currently I have a problem with getting my sleeping monitor to come out of sleep (even though the Mini is on and can be used via screen share and the like)... but I use a no mouse/keyboardless setup with synergy.
     
  8. thread starter macrumors 6502a

    Joined:
    Jun 14, 2012
    Location:
    Columbia, MD
    #8
    This is what I ended up doing. Sleep Never.
     
  9. macrumors member

    Joined:
    Oct 2, 2006
    #9
    The reason you are having troubles is because of the power nap and aggressive hibernation that Apple have set on these by default. You can have sleep, but you have to turn off Darkwake, and also turn off any hibernation states through pmset in terminal.

    I have proper sleep state working on my Mac Mini, and have a WOL relay setup on my home network so I can wake up and manage it remotely, which works great!
     
  10. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #10
    Power Nap doesn't apply to Mac minis. Only the MacBook Air (Late 2010, Mid 2011, Mid 2012) and MacBook Pro (Retina, Mid 2012) running Mountain Lion can use Power Nap.
     

Share This Page