Mac mini won't turn on

Discussion in 'Mac mini' started by SkyBell, Mar 7, 2008.

  1. macrumors 603

    SkyBell

    Joined:
    Sep 7, 2006
    Location:
    Texas, unfortunately.
    #1
    OK, so I was upgrading the RAM in my mini, and when I was finished, I pressed the power button. Well, the little light came on, but I couldn't hear anything. After about 3 or 4 seconds, the light went off.

    I'm pretty sure I put the RAM in right (As far as I could, but it doesn't seem far enough...) and I'm almost sure all the cables are reattached, except for one. Which is the Airport antenna, which I accidentally disconnected and can't find what to reconnect it too.

    So, can anyone tell me the problem?
     
  2. macrumors 65816

    Joined:
    May 14, 2003
    #2
    The airport antenna sits on the spring loaded post towards the rear of the unit if Im not mistaken.

    As far as the mini not turning on, Id say the ram isnt seated all the way in. When I first installed ram in my mini I didnt get the 2nd stick seated all the way and only 1 was showing up.
     
  3. macrumors newbie

    Joined:
    Jul 21, 2006
    #3
    Just open her back up and check everything and make sure the ram is properly fitted, those sticks are a bitch to get in sometimes. Sounds like ur ram isnt installed properly though.
     
  4. macrumors 601

    clyde2801

    Joined:
    Mar 6, 2008
    Location:
    In the land of no hills and red dirt.
    #4
    you didn't stick it all the way in!

    :D. Sorry, couldn't resist the title. Is the ram apple certified? I upgraded my ram to 3 gigs on my imac, and the 2 gig stick I bought at my local pc shop caused the imac not to come on. The little light at the lower right corner would just flash on and off. Got a refund for the stick, bought a 2 gig stick at my local 3rd party mac store (and paid only $20 bucks more) and the imac came on the first try.

    Assuming the ram you're installing is the right stuff, and is not defective, you haven't seated it fully. Good luck!
     
  5. macrumors 6502a

    JG271

    Joined:
    Dec 17, 2007
    Location:
    UK
    #5
    There is a small black power cable at the front that powers the hard drive and optical drive, make sure to push it down carefully. If the RAM is bad usually you'll get a few beeps...
     
  6. thread starter macrumors 603

    SkyBell

    Joined:
    Sep 7, 2006
    Location:
    Texas, unfortunately.
    #6
    Well, turns out I accidentally shoved something off of the logic board when I was opening it, so that's why it doesn't turn on.


    For as much as a new logic board costs, I might as well get a new mini.....*sigh*...
     
  7. macrumors newbie

    Joined:
    Aug 23, 2007
    #7
    If it was just one of the cables you pulled then they're really easy to put back.

    The Airport antennae has got a small round clip on the motherboard that you can just push into.

    If it was the wide copper cable that links the 2 boards you can open up the 'gripper' by pushing the small white plastic piece upwards; inserting the cable and then pushing the gripper back down to clamp.

    The RAM should insert with a definite snap and you shouldn't be able to see the contacts once it's in.
     
  8. thread starter macrumors 603

    SkyBell

    Joined:
    Sep 7, 2006
    Location:
    Texas, unfortunately.
    #8
    Well I eventually got the AirPort antennae back in, and even that copper cable back in, but the thing I shoved off the logic board is a little silver looking thing labeled "R36".
     
  9. macrumors 6502

    Joined:
    Nov 9, 2007
    Location:
    Lexington, KY
    #9
    Ouch, damn minis and their small margin for error.
     
  10. macrumors 65816

    Joined:
    May 14, 2003
    #10
    I just opened my mini for the last time ever tonight. Installed ram before I sell it. Ive opened it about 3 times before, bumping the ram from 512 to 1gb then to 2gb. Tonight was the fastest Ive ever gotten it open and switched out though, so I guess those previous disassemblies helped.

    I said it before and Ill say it again, for all the computers Ive put together and taken apart the mini is the most nerve racking. Would assume that was a transitor or capacitor that came off.
     
  11. macrumors regular

    killerwhack

    Joined:
    Aug 5, 2004
    Location:
    Los Angeles, California
    #11
    R36 "Shoved off"

    The "R" stands for resistor. Resitor 36 on the schematics.

    Sorry to learn of your misfortune.
     
  12. macrumors member

    Joined:
    May 25, 2008
    #12
    another cause

    OK, this is different from the rest of this thread, but I think the info might be useful to someone.

    I just bought a Mac Mini a few weeks ago, and I'm using it with an IOGear KVM switch. About a week ago I got a new Dell monitor. As soon as I swapped in the new monitor, the Mac became fussy and often wouldn't power on. Unplugging and replugging the Mac's power cord always seemed to fix the problem.

    The old monitor had a two-prong transformer; the new one has a regular 3-prong IEC power connector. So, I thought maybe the new monitor introduced a ground loop. So I tried adding a ground lift (three prong adapter, photo below) to the Mac's power cord, and problem solved!

    So if your Mac Mini won't power on, try lifting its ground.

    [​IMG]
     
  13. macrumors regular

    Joined:
    Feb 10, 2008
    Location:
    Great Britain
    #13
    The original thread is the exact same thing that happened to me.
    When I was opening it up, I saw inside and got confused.
    So i close her back up.
    After that the white light came on. And went off after 3/4 seconds.

    I dont recall knocking off or breaking any resistors.
     

Share This Page